Bug 124905 - RAMdisk doesn't keep its files
RAMdisk doesn't keep its files
Status: CLOSED DUPLICATE of bug 124904
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-06-01 07:49 EDT by Wouter Liefting
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Wouter Liefting 2004-06-01 07:49:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)

Description of problem:
After creating and mounting a RAM disk you can store files on it.
After unmounting and then mounting the RAM disk again these files are
gone. This used to work in other distributions and kernel versions.

Note: the fact that this does not work in itself is not a problem
since you should not use RAM disks for this but use shmfs instead. But
I've got the feeling that this a more fundamental bug somewhere in the
filesystem code, instead of a RAM disk bug. Hence the report.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
mkdir /mnt/ramdisk

dd if=/dev/zero of=/dev/ram0 bs=1024k count=4
mke2fs /dev/ram0

(Note - the RAM disk is now 16 MB instead of 4 MB. Strange...)

mount /dev/ram0 /mnt/ramdisk
df                                 (confirms that the FS size is 16 MB)
cp /etc/passwd /mnt/ramdisk/passwd
cat /mnt/ramdisk/passwd            (no problem)
umount /mnt/ramdisk

mount /dev/ram0 /mnt/ramdisk       (no problem so the filesystem info
is still there!)
cat /mnt/ramdisk/passwd            (no such file or directory!)
umount /mnt/ramdisk

Actual Results:
1. Filesystem is 16 MB
2. /mnt/ramdisk/passwd: no such file or directory

Expected Results:
1. Filesystem size should have been the size of the ramdisk - 4 MB
2. File should be there and viewable

Additional info:

This has always worked on 2.4 kernels and earlier. Does not work under
the default FC2 kernel, and the problem has been confirmed under
vanilla 2.6.6 as well.
Comment 1 Wouter Liefting 2004-06-01 07:54:08 EDT
Should not use the "back" button on my browser - this creates multiple
bug reports... :-(

*** This bug has been marked as a duplicate of 124904 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.