Bug 1249054 - Error when adding a schedule at the end of the month
Error when adding a schedule at the end of the month
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.4.3
Assigned To: Aparna Karve
Ramesh A
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 08:43 EDT by Sergio Ocon
Modified: 2015-10-22 10:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 10:33:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the configuration with the wrong date calculated (76.59 KB, image/png)
2015-07-31 08:43 EDT, Sergio Ocon
no flags Details

  None (edit)
Description Sergio Ocon 2015-07-31 08:43:36 EDT
Created attachment 1058050 [details]
Screenshot of the configuration with the wrong date calculated

Description of problem:
Today is July 31st, when creating a new schedule, it is by default defined to start at 0:0 of 07/32/2015

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to create schedule the last day of the month
2. Add a schedule
3.

Actual results:
It gives an error because the schedule is malformed

Expected results:
The suggested started date is correct

Additional info:
Comment 5 Aparna Karve 2015-09-16 16:38:31 EDT
To test the fix without having to wait for the end of the month, you can change your local date to the end of the month.
Comment 7 Ramesh A 2015-10-06 08:21:05 EDT
Good to go.  Verified and working fine in 5.4.3.0.20151001120745_d11cf59.
Comment 9 errata-xmlrpc 2015-10-22 10:33:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.