Bug 1249079 - [GSS] Add ceph-deploy command to push repository details to MON/OSD nodes, in the RHCS1.2.3 (Ubuntu) documentation
[GSS] Add ceph-deploy command to push repository details to MON/OSD nodes, in...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.2.3
All Linux
medium Severity medium
: rc
: 1.3.2
Assigned To: ceph-docs@redhat.com
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 09:05 EDT by Vimal Kumar
Modified: 2015-12-18 05:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 05:07:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Kumar 2015-07-31 09:05:14 EDT
a) Description of problem:

In 'Chapter 7' (Connect Monitor Hosts to Calamari) and 'Chapter 10' (Connect OSD Hosts to Calamari) of the Ubuntu installation guide for RHCS1.2.3, an additional step/command should be added which is needed prior to connecting the monitors and OSD nodes to the Calamari node.

The monitor nodes and OSD nodes should have the calamari node as the source repo to find the packages from. Else, trying to connect the monitors and OSD nodes to the calamari node will fail, without being able to find the packages.

<snip>
# ~/ceph-config# ceph-deploy calamari connect node1 node2 node3 node4 node5
    [ceph_deploy.conf][DEBUG ] found configuration file at: /root/ceph-config/cephdeploy.conf
    [ceph_deploy.cli][INFO  ] Invoked (1.5.26): /usr/bin/ceph-deploy calamari connect node1 node2 node3 node4 node5
    [ceph_deploy.cli][INFO  ] ceph-deploy options:
    [ceph_deploy.cli][INFO  ]  username                      : None
    [ceph_deploy.cli][INFO  ]  subcommand                    : connect
    [ceph_deploy.cli][INFO  ]  verbose                       : False
    [ceph_deploy.cli][INFO  ]  overwrite_conf                : False
    [ceph_deploy.cli][INFO  ]  prog                          : ceph-deploy
    [ceph_deploy.cli][INFO  ]  quiet                         : False
    [ceph_deploy.cli][INFO  ]  cd_conf                       : <ceph_deploy.conf.cephdeploy.Conf instance at 0x1a63440>
    [ceph_deploy.cli][INFO  ]  cluster                       : ceph
    [ceph_deploy.cli][INFO  ]  master                        : node1
    [ceph_deploy.cli][INFO  ]  func                          : <function calamari at 0x19c8140>
    [ceph_deploy.cli][INFO  ]  ceph_conf                     : None
    [ceph_deploy.cli][INFO  ]  hosts                         : ['node1', 'node2', 'node3', 'node4', 'node4']
    [ceph_deploy.cli][INFO  ]  default_release               : False
    [node1][DEBUG ] connected to host: node1
    [node1][DEBUG ] detect platform information from remote host
    [node1][DEBUG ] detect machine type
    [ceph_deploy.calamari][INFO  ] Distro info: Ubuntu 12.04 precise
    [ceph_deploy.calamari][INFO  ] assuming that a repository with Calamari packages is already configured.
    [ceph_deploy.calamari][INFO  ] Refer to the docs for examples (http://ceph.com/ceph-deploy/docs/conf.html)
    [node1][DEBUG ] creating config dir: /etc/salt/minion.d
    [node1][DEBUG ] creating the calamari salt config: /etc/salt/minion.d/calamari.conf
    [node1][INFO  ] Running command: env DEBIAN_FRONTEND=noninteractive apt-get install --assume-yes salt-minion
    [node1][DEBUG ] Reading package lists...
    [node1][DEBUG ] Building dependency tree...
    [node1][DEBUG ] Reading state information...
    [node1][WARNIN] E: Unable to locate package salt-minion
    [node1][ERROR ] RuntimeError: command returned non-zero exit status: 100
    [ceph_deploy][ERROR ] RuntimeError: Failed to execute command: env DEBIAN_FRONTEND=noninteractive apt-get install --assume-yes salt-minion
</snip>

To add the repo to the monitors and OSD nodes, the following command should be used:

# ceph-deploy install --repos <mon-node> <osd-node>...

This should be added in Chapter 7 (for the monitor node) and Chapter 10, for the OSD node.

b) Version-Release number of selected component (if applicable):

RHCS1.2.3 for Ubuntu
Comment 2 Nilamdyuti 2015-08-05 08:40:50 EDT
Fixed in the following commit:

https://gitlab.cee.redhat.com/ngoswami/red-hat-ceph-storage-installation-guide-ubuntu/commit/85024aa0492df5252aea1f04a3fcef2459a99949

See: https://gitlab.cee.redhat.com/ngoswami/red-hat-ceph-storage-installation-guide-ubuntu/blob/v1.2.3/quick-ceph-deploy.adoc#install-ceph

Added the step to copy repos to remote nodes before installing Ceph. Actually it is required there and is also displayed in the interactive shell of ice_setup after successfully installing Calamari. Also, adding this step before Ceph install means you don't have to run this step again before connecting monitor and OSD nodes to Calamari because ceph-deploy would now find the salt-minion package in the repo in remote node.
Comment 3 shylesh 2015-09-04 04:13:32 EDT
Proper command is added in the doc in  "Install ceph" section:
ceph-deploy install --repo node1 node2 node3 node4
ceph-deploy install node1 node2 node3 node4

Hence marking it as verified
Comment 4 Anjana Suparna Sriram 2015-12-18 05:07:08 EST
Fixed in 1.3.2 release.

Note You need to log in before you can comment on or make changes to this bug.