Bug 124909 - Matrox G550 DVI: frequency out of range
Matrox G550 DVI: frequency out of range
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 09:14 EDT by Richard Körber
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 09:43:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg logfile (36.09 KB, text/plain)
2004-07-07 13:11 EDT, Richard Körber
no flags Details
xorg configuration file (2.86 KB, text/plain)
2004-07-07 13:12 EDT, Richard Körber
no flags Details

  None (edit)
Description Richard Körber 2004-06-01 09:14:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I have a computer equipped with a Matrox G550 and an LG TFT monitor
connected by DVI only. I was able to do a graphical installation of
FC2 final on this machine, without any problems. G550 and the monitor
were properly detected and configured.

Anyhow after a reboot, when the X startup is ought to appear, the
monitor just reports that the frequencies are out of range. The
frequencies in the xorg.conf were in range of the monitor's
capabilities, though. Changing them didn't help either.

I have downloaded and installed the latest driver from the Matrox
homepage, and then everything worked fine even with the original
configuration.

I remember that I have had the same issue with FC1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a computer with Matrox G550 card.
2. Connect a LG TFT by DVI.
3. Just install FC2 and wait until it reboots for the first time.
    

Actual Results:  When the X startup is ought to appear, the screen
goes dark and the monitor reports that the frequencies are out of range.

Expected Results:  The X startup and eventually the login mask appears.

Additional info:

Workaround: Get the latest driver from the Matrox homepage. You have
to copy the files to the appropriate place manually, since the Matrox
installer script thinks that the driver is up-to-date, which is not true.
Comment 1 Mike A. Harris 2004-07-05 17:58:53 EDT
Using the mga driver provided by Red Hat, please try to reproduce this
problem again, and capture the X server log and X server config file
from the failed attempt to start the server.

Attach the files to the bug report using the link below as
individual uncompressed attachments and we'll troubleshoot this
based upon the attached files.

Thanks in advance.
Comment 2 Richard Körber 2004-07-07 13:11:35 EDT
Created attachment 101686 [details]
Xorg logfile
Comment 3 Richard Körber 2004-07-07 13:12:31 EDT
Created attachment 101687 [details]
xorg configuration file
Comment 4 Richard Körber 2004-07-07 13:28:14 EDT
Please find the logfile and config file in the attachment pool.

Note that the server seems to start up just fine, only the frequencies
are out of range. Unfortunately I cannot find out the actual
frequencies since my monitor does not show them.

For the file: my monitor is a LG Flatron 885LE.
Comment 5 Mike A. Harris 2004-09-14 14:10:03 EDT
The "mga" driver manpage indicates the following:


DESCRIPTION
       mga  is  an XFree86 driver for Matrox video cards.  The driver
is fully
       accelerated, and provides support for the following framebuffer
depths:
       8,  15,  16,  24,  and an 8+24 overlay mode.  All visual types
are sup-
       ported for depth 8, and both TrueColor and DirectColor visuals
are sup-
       ported  for  the  other  depths except 8+24 mode which supports
Pseudo-
       Color, GrayScale and TrueColor.   Multi-card  configurations 
are  sup-
       ported.   XVideo  is  supported  on G200 and newer systems,
with either
       TexturedVideo or video overlay.  The second head of dual-head
cards  is
       supported  for  the G450 and G550.  Support for the second head
on G400
       cards requires a binary-only "mga_hal" module that  is 
available  from
       Matrox  <http://www.matrox.com>, and may be on the CD supplied
with the
       card.  That module also provides various other enhancements,
and may be
       necessary  to  use  the  DVI  (digital)  output  on the G550
(and other
       cards).


Output to DVI on G550 seems to be experimental only, and not
officially supported, which seems to explain the transient
behaviour you're experiencing.  You may wish to file a bug report
at http://bugs.freedesktop.org in the "xorg" component however,
and the driver maintainer may be able to comment on the issue
and/or provide a fix for a future release.

Once you've filed your X.Org bug report, we will track the issue
in the freedesktop.org bugzilla if you paste the URL here to the
bug report.

Thanks in advance.
Comment 6 Matthias Link 2004-10-17 17:34:24 EDT
Hi!

I'm using the G550 on FC2 on i686 with a SyncMaster 181T at a DVI-Port and experienced 
exactly the same issue.

Copied the files manually from the original matrox driver to the appropriate directories 
and everything works fine!

Is there any possibility to fix this? It's already happening since Red Hat 9.0 (or even 
earlier!)!
Comment 7 Richard Körber 2004-10-17 18:00:20 EDT
For your information: I have sold my G550 meanwhile and left Matrox
for good. There were other serious issues with the original Matrox
driver, which were kept unresolved for more than a year now. It seems
like Matrox has discontinued to support the Linux platform.

I am sorry, but I am not available for this bug any more.
Comment 8 Mike A. Harris 2004-10-17 20:11:33 EDT
> Additional Comment #6 From Matthias Link (matthias.link@t-com.net)
>  on 2004-10-17 17:34 
>Is there any possibility to fix this? It's already happening since
>Red Hat 9.0 (or even earlier!)!

Yes, please report the issue to X.Org, by filing a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in
the "xorg" component.

Once you've filed your X.Org bug report, if you paste the bug
report URL here, we will track the issue in the freedesktop.org
bugzilla and review any fixes that become available for possible
inclusion in future updates.

Please update the bug status once you have filed the report in
X.Org bugzilla.

Thanks in advance.
Comment 9 Mike A. Harris 2005-04-11 09:43:52 EDT
Closing bug as "WONTFIX" as this is a limitation present in the mga
driver which will only change if Matrox provides X.Org developers
with documentation for the G550.  That seems unlikely at this point.


Note You need to log in before you can comment on or make changes to this bug.