Bug 1249090 - RFE: Installing pcp-collector package should enable pmcd and pmlogger services by default
RFE: Installing pcp-collector package should enable pmcd and pmlogger service...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nathan Scott
Miloš Prchlík
: FutureFeature
Depends On: 1243809
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 09:21 EDT by Lukas Berk
Modified: 2015-11-19 06:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:55:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Berk 2015-07-31 09:21:09 EDT
Description of problem:
Currently, installing the pcp-collector package will provide users with PCP's various collection agents and logging functionality.  However, they must still explicitly enable each service, despite the package's intent as a single-rpm setup mechanism.

If users would like to install pcp, and inspect the configuration files before launching the service(s), they are still able to do so by installing the base pcp package.  This pcp-collector package change will simply allow for those looking to expedite the process, immediately making use of pcp functionality, to do so.

Version-Release number of selected component (if applicable):
3.10.5

How reproducible: Always


Steps to Reproduce:
1. yum install pcp-collector
2. systemctl status pmcd && systemctl status pmlogger
3.

Actual results:
Services are not started/enabled

Expected results:
Services should be started/enabled
Comment 2 Nathan Scott 2015-08-04 23:01:06 EDT
pcp-3.10.6-1 el7 build contains this change.
Comment 4 Miloš Prchlík 2015-10-14 10:50:27 EDT
Verified for build pcp-3.10.6-2.el7.
Comment 5 errata-xmlrpc 2015-11-19 06:55:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2096.html

Note You need to log in before you can comment on or make changes to this bug.