Bug 1249095 - (kf5-kcm_wacomtablet) kcm_wacomtablet not usable and no notifications available for wacom tablets in plasma 5
kcm_wacomtablet not usable and no notifications available for wacom tablets i...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kcm_wacomtablet (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mario Santagiuliana
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: plasma5
  Show dependency treegraph
 
Reported: 2015-07-31 09:29 EDT by Alberto Ferrante
Modified: 2015-09-18 14:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.1.0-2.20150702gitg8ad842e.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 13:22:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alberto Ferrante 2015-07-31 09:29:25 EDT
Description of problem:
The kcm_wacomtabled shipped in Fedora 22 (KDE spin) is for Plasma 4 and does not work in Plasma 5. Furthermore, no notifications for Wacom tablets are available in the notification system (therefore, no automatic action can be performed when the tablet is connected).

Version-Release number of selected component (if applicable):
2.0.2-1

How reproducible:
Go in system settings: no icon for configuring Wacom tablets is available. Typing kcmshell4 kcm_wacomtablet a windows is shown with the error "KDE tablet service not found". The service is not available for being enabled.

In System Settings -> Notifications, no actions for Wacom tablets are available.

Steps to Reproduce:
1.
2.
3.

Actual results:
No graphical interface for configuring Wacom tablets; no notifications related to graphic tablets


Expected results:
A working interface for Wacom tablets, notifications for events related to the tablets

Additional info:
Comment 1 Rex Dieter 2015-07-31 09:32:29 EDT
True, no one has ported kcm-wacomtablet to kde frameworks 5 (yet).  Marking FutureFeature
Comment 2 Rex Dieter 2015-07-31 09:34:50 EDT
Looks like there is an upstream kf5-port branch, where some work is underway.  I'll try to find out if it is at least testable in the current state (development snapshot).
Comment 3 Fedora Update System 2015-09-03 05:52:18 EDT
kcm_wacomtablet-2.1.0-2.20150702gitg8ad842e.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kcm_wacomtablet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14904
Comment 4 Alberto Ferrante 2015-09-03 14:08:43 EDT
Thanks!
Any possibility of having the package also for Fedora 22?
Comment 5 Rex Dieter 2015-09-03 14:17:56 EDT
Yes
Comment 6 Jason Tibbitts 2015-09-03 14:23:42 EDT
I pushed it to F22 at the same time as I pushed it to F23.  I guess it just hasn't actually been sent to the mirrors yet, but you can search bodhi for it, or just download the build from koji.
Comment 7 Fedora Update System 2015-09-03 15:20:34 EDT
kcm_wacomtablet-2.1.0-2.20150702gitg8ad842e.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kcm_wacomtablet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14905
Comment 8 Alberto Ferrante 2015-09-08 12:32:42 EDT
After some days of testing I can say that it works for me in Fedora 22 (I am mostly using the notifications to trigger my configuration script, I haven't used the configuration interface much, but it seems to work).
Comment 9 Jason Tibbitts 2015-09-08 14:12:29 EDT
Please do give that feedback in the update.
Comment 10 Fedora Update System 2015-09-11 13:22:22 EDT
kcm_wacomtablet-2.1.0-2.20150702gitg8ad842e.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-09-18 14:51:25 EDT
kcm_wacomtablet-2.1.0-2.20150702gitg8ad842e.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.