Bug 1249101 - Use timeout in abrt-console-notification.sh
Use timeout in abrt-console-notification.sh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Matej Habrnal
Martin Kyral
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 09:35 EDT by Matej Habrnal
Modified: 2017-09-09 13:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: abrt-2.1.11-39.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:06:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch 1/1: console-notifications: add timeout (869 bytes, patch)
2016-05-04 03:27 EDT, Matej Habrnal
no flags Details | Diff

  None (edit)
Description Matej Habrnal 2015-07-31 09:35:19 EDT
Description of problem:
abrt-console-notification tries to run "abrt-cli status" on every login. If there is an ".lock" symlink in one of the problem directories (the directory is locked), abrt-cli waits until the locked directory is unlocked. 

This causes users must wait until the abrt-dbus kills the abrt-cli. It takes about ~50 seconds which is a lot.

How reproducible:
Always

Steps to Reproduce:
1. Create .lock symlink in one of the problem directories 
   "# ln -sf $PROBLEM_DIRECTORY/.lock "
2. Run "$ sh -l -i -c "echo test" "

Actual results:
abrt-cli status runs until the abrt-dbus's timeout is reached.

Expected results:
abrt-console-notification kills the abrt-cli after abrt-console-notification's timeout is reached (10 seconds) and prints a message about what happened.

Additional information:
This is easy fix and this commit fixes the issue on Fedora:
https://github.com/abrt/abrt/commit/589bd45f887debcd74302c6881c9c6552e3563a7
Comment 4 Matej Habrnal 2016-05-04 03:27:07 EDT
Created attachment 1153723 [details]
Patch 1/1: console-notifications: add timeout
Comment 7 errata-xmlrpc 2016-11-03 23:06:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2307.html

Note You need to log in before you can comment on or make changes to this bug.