Bug 1249118 - On additional hosts, appending an answerfile, the setup will not download the HE one from the first host
On additional hosts, appending an answerfile, the setup will not download the...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.5.4
Unspecified Unspecified
unspecified Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Simone Tiraboschi
Artyom
: Triaged, ZStream
Depends On:
Blocks: 1245143 1249514
  Show dependency treegraph
 
Reported: 2015-07-31 10:19 EDT by Simone Tiraboschi
Modified: 2016-03-09 14:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, ovirt-hosted-engine-setup assumed that if an answer file was passed to the command line on an additional host, it was generated by ovirt-hosted-engine-setup in a previous execution on the first host. When the host is RHEV-H an answer file is always passed to ovirt-hosted-engine-setup. On additional hosts based on RHEV-H, the ovirt-hosted-engine-setup failed. With this release, an additional question has been added to setup to confirm whether the answer file is the one generated on the first host. Now setup works on additional hosts.
Story Points: ---
Clone Of:
: 1249514 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:13:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44161 master MERGED packaging: setup: avoid assumption on answerfile Never
oVirt gerrit 44240 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: avoid assumption on answerfile Never

  None (edit)
Description Simone Tiraboschi 2015-07-31 10:19:27 EDT
Description of problem:
On additional host the setup assumes that any appended answerfile was completely generated on the first host and so it skip downloading it.
RHEV-H always generates and appends a partial answerfile and so on HE additional RHEV-H nodes the first host answerfile never got downloaded while it's required to correctly complete the setup sequence.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. deploy an additional HE node on  RHEV-H
2.
3.

Actual results:
The setup fails.

Expected results:
It completes the setup sequence.

Additional info:
Comment 2 Artyom 2015-09-02 06:44:35 EDT
Verified on ovirt-hosted-engine-setup-1.3.0-0.4.beta.git42eb801.el7ev.noarch
run deployment on additional host with some partial config, but setup anyway ask me if I want to download config from first host
Comment 4 errata-xmlrpc 2016-03-09 14:13:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html

Note You need to log in before you can comment on or make changes to this bug.