This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1249121 - Review of totpcgi-selinux package
Review of totpcgi-selinux package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: totpcgi (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 10:25 EDT by Miroslav Grepl
Modified: 2015-08-10 06:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: totpcgi-0.5.5-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 06:09:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
totpcgi-selinux.patch (1.33 KB, patch)
2015-07-31 10:25 EDT, Miroslav Grepl
no flags Details | Diff

  None (edit)
Description Miroslav Grepl 2015-07-31 10:25:43 EDT
Created attachment 1058069 [details]
totpcgi-selinux.patch

Description of problem:

Due to https://fedoraproject.org//wiki/Changes/SELinuxPolicyStoreMigration we test all packages shipping own SELinux policy. 

totpcgi.pp SELinux policy module can not be loaded because of missing optional_policy() blocks.

Version-Release number of selected component (if applicable):

$ rpm -q totpcgi-selinux selinux-policy-targeted
totpcgi-selinux-0.5.5-5.fc23.noarch
selinux-policy-targeted-3.13.1-138.fc23.noarch


How reproducible:

# semodule -i totpcgi.pp

Actual results:

# semodule -i totpcgi.pp
Failed to resolve typeattributeset statement at 108 of /var/lib/selinux/targeted/tmp/modules/400/totpcgi/cil
Failed to resolve ast
semodule: Failed!


Expected results:

semodule --list-modules=full |grep tot
400 totpcgi                  pp

after installation.

Additional info:
Comment 1 Fedora Update System 2015-08-05 18:37:07 EDT
totpcgi-0.5.5-6.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/totpcgi-0.5.5-6.fc23
Comment 2 Fedora Update System 2015-08-06 11:59:32 EDT
Package totpcgi-0.5.5-6.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing totpcgi-0.5.5-6.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12826/totpcgi-0.5.5-6.fc23
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2015-08-10 06:09:51 EDT
totpcgi-0.5.5-6.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.