Bug 1249123 - pmieconf fails on empty -c file
pmieconf fails on empty -c file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pcp (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nathan Scott
Fedora Extras Quality Assurance
:
: 1374703 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 10:39 EDT by Frank Ch. Eigler
Modified: 2016-10-25 20:58 EDT (History)
7 users (show)

See Also:
Fixed In Version: pcp-3.11.5-1.el5 pcp-3.11.5-1.fc24 pcp-3.11.5-1.fc23 pcp-3.11.5-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-25 12:16:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2015-07-31 10:39:04 EDT
% touch /tmp/foo
% pmieconf -F -c -f /tmp/foo
pmieconf: error - /tmp/foo is not a rule customization file (bad header)

pmieconf should be willing to start from an empty file (which could have resulted from crashes or earlier failed runs).
Comment 1 Jan Kurik 2016-02-24 08:30:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Nathan Scott 2016-09-26 02:25:51 EDT
*** Bug 1374703 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2016-09-27 16:21:56 EDT
pcp-3.11.5-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d14b648a5
Comment 4 Fedora Update System 2016-09-28 01:56:54 EDT
pcp-3.11.5-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca5c041e73
Comment 5 Fedora Update System 2016-09-28 02:25:22 EDT
pcp-3.11.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b32e6fdc78
Comment 6 Fedora Update System 2016-09-28 21:16:05 EDT
pcp-3.11.5-1.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-63742f1d5b
Comment 7 Fedora Update System 2016-10-25 12:16:49 EDT
pcp-3.11.5-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-10-25 16:21:37 EDT
pcp-3.11.5-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-10-25 19:50:44 EDT
pcp-3.11.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-10-25 20:58:05 EDT
pcp-3.11.5-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.