Bug 1249136 - Agent auto upgrade fails because a jar install is installed to the default rpm directory
Agent auto upgrade fails because a jar install is installed to the default rp...
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.3.3
Unspecified Unspecified
unspecified Severity low
: ---
: JON 3.3.5
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 11:21 EDT by dsteigne
Modified: 2015-11-19 10:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 10:12:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2015-07-31 11:21:36 EDT
Description of problem:
Is there another way to check for an agent rpm install? If the customer just happens to install a jar agent installation to the default rpm directory /opt/jon/rhq-agent the upgrade fails with "An agent RPM installation was found in .."

Version-Release number of selected component (if applicable):
3.3.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Larry O'Leary 2015-11-19 10:12:43 EST
After reviewing the information from the original report, it has been determined that there may have been a misunderstanding regarding the message.

The message does not indicate that the agent update could not be performed. It only warned that the system also included an RPM installed agent and that the apply-update utility WOULD NOT update the RPM but only the ZIP installed agent.

Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.