Bug 1249151 - cloud-init parameters not being passed to rhev
cloud-init parameters not being passed to rhev
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.3.0
All All
medium Severity medium
: GA
: 5.4.2
Assigned To: Brandon Dunne
Dave Johnson
: ZStream
Depends On: 1238390
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 12:11 EDT by Chris Pelland
Modified: 2015-09-09 09:10 EDT (History)
15 users (show)

See Also:
Fixed In Version: 5.4.2.0
Doc Type: Bug Fix
Doc Text:
Provisioning a virtual machine in CloudForms Management Engine from a template on a RHEV provider using cloud-init did not pass any settings from the customize tab to cloud-init and deployed a virtual machine without the requested customizations. This process worked fine with RHEV 3.3. This bug was a result of a process change in the way RHEV accepts the cloud-init data in the newer versions. To allow cloud-init to function properly again, a method was added to handle the customized cloud-init configuration attributes and new API endpoints were used on the newer versions of RHEV. Customized provisioning works as expected in the latest version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1238390
Environment:
Last Closed: 2015-09-09 08:26:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Brandon Dunne 2015-08-19 07:24:53 EDT
Shikha,

The new doc text is not true.  This has worked before with RHEV 3.3, the way that RHEV accepts the cloud-init data changed in 3.4.  The changes in this bug take into account both methods of attaching cloud-init data and uses the new API endpoints on the newer versions of RHEV allowing cloud-init to function properly again.
Comment 6 errata-xmlrpc 2015-09-09 08:26:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1744.html

Note You need to log in before you can comment on or make changes to this bug.