Bug 1249157 - Both plasma-workspace and kde-runtime provide org.kde.kuiserver dbus service
Both plasma-workspace and kde-runtime provide org.kde.kuiserver dbus service
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-runtime (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 12:31 EDT by Orion Poplawski
Modified: 2017-02-10 13:06 EST (History)
11 users (show)

See Also:
Fixed In Version: kde-runtime-15.08.2-1.fc23 kde-runtime-15.08.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 00:52:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 351500 None None None Never

  None (edit)
Description Orion Poplawski 2015-07-31 12:31:07 EDT
Description of problem:

# grep org.kde.kuiserver /usr/share/dbus-1/*/*
/usr/share/dbus-1/services/kf5_org.kde.kuiserver.service:Name=org.kde.kuiserver
/usr/share/dbus-1/services/org.kde.kuiserver.service:Name=org.kde.kuiserver

# rpm -qf /usr/share/dbus-1/services/kf5_org.kde.kuiserver.service /usr/share/dbus-1/services/org.kde.kuiserver.service
plasma-workspace-5.3.2-5.fc24.x86_64
kde-runtime-15.04.3-1.fc23.x86_64

Leads to:

[   38.319496] systemd-dbus1-generator[1214]: Failed to create /run/user/0/systemd/generator.late/dbus-org.kde.kuiserver.service: File exists

Jul 31 10:20:44 vmrawhide systemd: Failed to create /run/user/494/systemd/generator.late/dbus-org.kde.kuiserver.service: File exists
Jul 31 10:20:45 vmrawhide systemd-dbus1-generator[1214]: Failed to create /run/user/0/systemd/generator.late/dbus-org.kde.kuiserver.service: File exists
Comment 1 Orion Poplawski 2015-07-31 12:33:04 EDT
Actually, I suspect it is more appropriate to be removing from kde-runtime.
Comment 2 Lennart Poettering 2015-07-31 13:16:32 EDT
(note that this only becomes more visible with kdbus, it's already broken with dbus-daemon, as it's not clear which service will be activated when requested. dbus-daemon doesn't warn about this, but it probably should too)
Comment 3 Rex Dieter 2015-08-19 17:29:26 EDT
Filed bug upstream,
https://bugs.kde.org/show_bug.cgi?id=351500
Comment 4 Rex Dieter 2015-10-12 12:55:49 EDT
Patch submitted upstream for review:
https://git.reviewboard.kde.org/r/125610/


Reassigning to plasma-workspace (for now), current implementation is to use separate org.kde.kuiserver5 service for kf5/plasma5 runtime.
Comment 5 Rex Dieter 2015-10-12 13:27:05 EDT
OK, upstream knocked down that idea.  

Next plan:
* omit kuiserver bits from kde-runtime
Comment 6 Fedora Update System 2015-10-14 14:38:42 EDT
kde-baseapps-15.08.2-1.fc23 kde-runtime-15.08.2-1.fc23 kdelibs-4.14.13-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-22d451b685
Comment 7 Fedora Update System 2015-10-14 18:52:35 EDT
kde-baseapps-15.08.2-1.fc23, kde-runtime-15.08.2-1.fc23, kdelibs-4.14.13-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kde-baseapps kde-runtime kdelibs'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-22d451b685
Comment 8 Fedora Update System 2015-10-31 22:37:28 EDT
kde-baseapps-15.08.2-1.fc23, kde-runtime-15.08.2-1.fc23, kdelibs-4.14.13-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-11-04 09:22:09 EST
kde-runtime-15.08.2-1.fc22 kdelibs-4.14.13-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2bac384722
Comment 10 Fedora Update System 2015-11-05 10:52:40 EST
kde-runtime-15.08.2-1.fc22, kdelibs-4.14.13-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kdelibs kde-runtime'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2bac384722
Comment 11 Fedora Update System 2015-11-11 00:52:30 EST
kde-runtime-15.08.2-1.fc22, kdelibs-4.14.13-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Sergio Monteiro Basto 2015-11-12 20:55:20 EST
(In reply to Rex Dieter from comment #5)
> OK, upstream knocked down that idea.  
> 
> Next plan:
> * omit kuiserver bits from kde-runtime

Like 0001-make-kglobalaccel-khelpcenter-kuiserver-bits-optiona.patch says:
"Allow some items to be disabled that could undesirable on plasma5"
but it is desired on KDE4, which I'm running on my laptop within F23 . 
I notice that is just undefine plasma5 in kde-runtime.spec, good !.  

I saw this issue when run in command line:
ark --batch  -a kde-workspace-4.11.22-5.fc23.src.rpm 

ark(17127): Couldn't start kuiserver from kuiserver.desktop:  "Could not find service 'kuiserver.desktop'." 
QDBusObjectPath: invalid path ""

but ark is not modified . 

I like more the idea of: "Exclusively use org.kde.kuiserver5 dbus service so it doesn't conflict with kde4's org.kde.kuiserver from kde-runtime"
Comment 13 Rex Dieter 2015-11-13 08:52:15 EST
Did error/warning prevent ark from functioning properly?

Are you not using plasma(5)?
Comment 14 Sergio Monteiro Basto 2015-11-13 11:02:04 EST
no, ark works well, without problems. 
 
yes I had install kde4 over F23 with :

dnf copr enable sergiomb/kde4for23 ,  it is a copy of dnf copr enable peem/kde4-fedora , that we talk about on KDE mailing list ,emails with subject kde4 in F22

Thanks
Comment 15 Rex Dieter 2015-11-16 15:08:34 EST
OK, for folks that want/need it, I suppose I can bring back a kde-runtime-kuiserver subpkg
Comment 16 Sergio Monteiro Basto 2015-11-17 20:42:58 EST
(In reply to Rex Dieter from comment #15)
> OK, for folks that want/need it, I suppose I can bring back a
> kde-runtime-kuiserver subpkg

I don't know if it's worth , because looking for kde-runtime.spec [1] 
I want build kde-runtime without plasma5 defined, to have also kdesu, khelpcenter etc 


[1] https://pkgs.fedoraproject.org/cgit/kde-runtime.git/tree/kde-runtime.spec


Thanks,
Comment 17 Sergio Monteiro Basto 2015-12-02 20:09:24 EST
(In reply to Rex Dieter from comment #15)
> OK, for folks that want/need it, I suppose I can bring back a
> kde-runtime-kuiserver subpkg

On second thought [1] maybe I don't need rebuild kde-runtime and is a good idea create a kde-runtime-kuiserver subpkg 

Thanks.

[1] https://lists.fedoraproject.org/archives/list/kde%40lists.fedoraproject.org/message/HCZPQKLY6ER4EDHS4Z2ECBI7UCLHUTUF/
Comment 18 Rex Dieter 2015-12-18 14:27:12 EST
%changelog
* Fri Dec 18 2015 Rex Dieter <rdieter@fedoraproject.org> 15.12.0-1
- 15.12.0, - restore -kuiserver (#1249157)
Comment 19 Sergio Monteiro Basto 2017-02-08 02:39:52 EST
(In reply to Sergio Monteiro Basto from comment #16)
> I don't know if it's worth , because looking for kde-runtime.spec [1] 
> I want build kde-runtime without plasma5 defined, to have also kdesu,
> khelpcenter etc 

My sentence here is not correct, I use kde-runtime from system (just add %global kuiserver 1 ) 

(In reply to Rex Dieter from comment #5)
> OK, upstream knocked down that idea.  
> 
> Next plan:
> * omit kuiserver bits from kde-runtime

I like the idea (the implementation to use separate org.kde.kuiserver5 service for kf5/plasma5 runtime ) 

Now we have Obsoletes: kde-runtime-kuiserver < 1:15.08.2 on plasma-workspace.spec [1] 

Why we can have org.kde.kuiserver5 for kuiserver5 and org.kde.kuiserver for kuiserver (kde4) ? 

Should be always a good solution not overwrite, files from previous versions , we got
this problem several times , and in my IMHO is a better solution, I have the same problem with https://bugzilla.redhat.com/show_bug.cgi?id=1199720 ... 

Should I open a new bug ? , maybe is the better to explain the problem and find a solution ... 


[1] 
https://src.fedoraproject.org/cgit/rpms/plasma-workspace.git/tree/plasma-workspace.spec#n280
Comment 20 Rex Dieter 2017-02-08 07:20:27 EST
Why we can have ... ?  

See
https://git.reviewboard.kde.org/r/125610/


If you want kde-runtime-kuiserver, you'll need to maintain it yourself, sorry.
Comment 21 Sergio Monteiro Basto 2017-02-10 13:04:04 EST
Thanks for reply, my solution was add Epoch:3 to kde-runtime.spec 
and therefore 
Obsoletes: kde-runtime-kuiserver < 1:15.08.2 in plasma-workspace.spec 
and 
Obsoletes: kde-runtime-docs < 1: (...) in plasma-desktop-doc 

are ignored .
Comment 22 Rex Dieter 2017-02-10 13:06:58 EST
Epoch: 1 
would have been enough, but 3 works too

Note You need to log in before you can comment on or make changes to this bug.