Bug 1249188 - Kernel panic on first boot
Kernel panic on first boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 14:39 EDT by Bernardo Donadio
Modified: 2015-09-14 19:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 19:40:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of kernel panic (3.30 MB, image/jpeg)
2015-07-31 14:39 EDT, Bernardo Donadio
no flags Details

  None (edit)
Description Bernardo Donadio 2015-07-31 14:39:46 EDT
Created attachment 1058108 [details]
Photo of kernel panic

Description of problem:
Just after doing a clean install of Fedora 22 (Fedora-Live-Workstation-x86_64-22-3.iso), the system is unable to boot, freezing with the following kernel panic:

"BUG: Unable to handle kernel NULL pointer dereference at IP: [<ffffffff81251fa8>] pin_remove+0x58/0xc0"

Version-Release number of selected component (if applicable): 
4.0.4-301.fc22.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 22.
2. Try to boot from disk (remove rhgb and quiet from options, and add nomodeset).
3. Wait boot for 2 minutes and encounter the kernel panic above.

Also reproducible without the boot options, but there's no message shown then.

Actual results:
Kernel panic.

Expected results:
Minimally working system after installation.

Additional info:
rescue mode also isn't able to boot. This system was working fine with Fedora 21 until kernel 3.17. Linux 3.18 made some changes related systemd and disk handling and since then wasn't able to boot (no kernel panic, although).
It's a A890GXM-A mobo, with a Phenom II x4 965 processor, and a NVIDIA GeForce GTX570 attached. System installed in a Corsair SSD with ext4 on top of LVM (the boot takes 2 minutes because systemd stalls trying to mount some filesystem).

Clean install from anaconda, all in the first boot.
Comment 1 Josh Boyer 2015-08-03 09:17:41 EDT
The image you've attached doesn't contain enough information for us to determine where the problem might lie.  Is it possible to get an image with more of the backtrace?
Comment 2 Bernardo Donadio 2015-09-14 19:40:01 EDT
After further inspection, I was led to believe that this error was, in fact, caused by a underlying hardware issue. I was unable to reproduce it since then.

Note You need to log in before you can comment on or make changes to this bug.