Bug 1249263 - Search is useless
Search is useless
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 21:34 EDT by Robin Laing
Modified: 2015-11-18 12:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 12:41:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Laing 2015-07-31 21:34:30 EDT
Description of problem: fully updated FC22 running Yumex-dnf and I cannot search as I could in normal yumex.  If I search for Video, I get no results.  If I search for KDE I only get older KDE packages, I don't get any of the KDE (kf5) packages listed.

Search seems to be linked to the actual file name, nothing to do with descriptions or groupings.  I cannot search for debug for individual packages.  I only get debugmode for a result.


Version-Release number of selected component (if applicable):
yumex-dnf-4.1.2-1.fc22.noarch


How reproducible:  Every time I try.


Steps to Reproduce:
1. Open Yumex-dnf
2. Search for something other than the start of a package, such as debug.
3. results are much less than expected.

Actual results:  Searching for debug only listed debugmode.


Expected results: display all the debug modules available.


Additional info:  this makes finding applications with Yumex useless.  Removing old packages is impossible if you cannot search for them.
Comment 1 Robin Laing 2015-07-31 21:42:07 EDT
I see that there are selections for search options but they don't meet the level of the previous yumex.

Selection of just selected keywords or still doesn't find all the related items.

Full selection in a search for FC21 packages still installed on my system shows just one item with every selected but if I do an RPM -qa |grep fc21 I get 196 items.

I would like the ability to search all the included information available in one search.
Comment 2 Robin Laing 2015-09-06 23:16:37 EDT
Today while searching for libraries, I couldn't find everything that was available that I needed.

Needed to do three searches to find that I still couldn't find what was necessary.

It would have been better to modify the original Yumex to work with DNF than a re-write.  I have more bugs to issue on yumex-dnf when time permits.
Comment 3 Tim Lauridsen 2015-10-06 05:57:58 EDT
You should properly read the online documentation on how the search is working in yumex-dnf

http://yumex-dnf.readthedocs.org/en/latest/main.html

yumex-dnf is not yumex and search is working different, dnf API is different than yum API, when it comes to search.

Feel welcome to come with usecases to stuff to search for, It will be more useful, so I can improve the search.

Note You need to log in before you can comment on or make changes to this bug.