Bug 1249266 - ValueError: not enough free space in volume group
ValueError: not enough free space in volume group
Status: CLOSED DUPLICATE of bug 1246901
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:99a24bab70edc897f00ab5521d9...
:
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-07-31 22:20 EDT by Adam Williamson
Modified: 2015-08-03 04:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-03 04:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (282.03 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: anaconda.log (22.02 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: dnf.log (1.05 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: environ (494 bytes, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: lsblk_output (1.37 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: nmcli_dev_list (1.25 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: os_info (451 bytes, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: program.log (17.70 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: storage.log (63.92 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: syslog (63.72 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: ifcfg.log (2.23 KB, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details
File: packaging.log (147 bytes, text/plain)
2015-07-31 22:20 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-07-31 22:20:43 EDT
Description of problem:
Boot 23 Alpha TC2 with a single empty disk, go to custom partitioning, change scheme to LVM Thin Partitioning, click 'create them automatically'.

Version-Release number of selected component:
anaconda-23.17-1

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/lvm.py", line 618, in _setSize
    raise ValueError("not enough free space in volume group")
  File "/usr/lib/python3.4/site-packages/blivet/devices/lvm.py", line 1509, in _setSize
    super(LVMThinLogicalVolumeDevice, self)._setSize(size)
  File "/usr/lib/python3.4/site-packages/blivet/partitioning.py", line 1863, in _apply_chunk_growth
    req.device.size = size
  File "/usr/lib/python3.4/site-packages/blivet/partitioning.py", line 1923, in growLVM
    _apply_chunk_growth(thin_chunk)
  File "/usr/lib/python3.4/site-packages/blivet/autopart.py", line 505, in doAutoPartition
    growLVM(storage)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2325, in _do_autopart
    min_luks_entropy=crypto.MIN_CREATE_ENTROPY)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 135, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2372, in on_create_clicked
    self._do_autopart()
ValueError: not enough free space in volume group

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-23_A_T2-x86_64 quiet
dnf.rpm.log:    Aug 01 02:19:26 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc3.git4.1.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Adam Williamson 2015-07-31 22:20:46 EDT
Created attachment 1058196 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2015-07-31 22:20:47 EDT
Created attachment 1058197 [details]
File: anaconda.log
Comment 3 Adam Williamson 2015-07-31 22:20:48 EDT
Created attachment 1058198 [details]
File: dnf.log
Comment 4 Adam Williamson 2015-07-31 22:20:49 EDT
Created attachment 1058199 [details]
File: environ
Comment 5 Adam Williamson 2015-07-31 22:20:50 EDT
Created attachment 1058200 [details]
File: lsblk_output
Comment 6 Adam Williamson 2015-07-31 22:20:51 EDT
Created attachment 1058201 [details]
File: nmcli_dev_list
Comment 7 Adam Williamson 2015-07-31 22:20:51 EDT
Created attachment 1058202 [details]
File: os_info
Comment 8 Adam Williamson 2015-07-31 22:20:52 EDT
Created attachment 1058203 [details]
File: program.log
Comment 9 Adam Williamson 2015-07-31 22:20:54 EDT
Created attachment 1058204 [details]
File: storage.log
Comment 10 Adam Williamson 2015-07-31 22:20:55 EDT
Created attachment 1058205 [details]
File: syslog
Comment 11 Adam Williamson 2015-07-31 22:20:56 EDT
Created attachment 1058206 [details]
File: ifcfg.log
Comment 12 Adam Williamson 2015-07-31 22:20:57 EDT
Created attachment 1058207 [details]
File: packaging.log
Comment 13 Adam Williamson 2015-07-31 22:23:36 EDT
Proposing as a Beta blocker:

"When using the custom partitioning flow, the installer must be able to:  ... Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions" - https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Custom_partitioning . Assuming we count LVM thin partitioning. If not, this would be a Final blocker.
Comment 14 Vojtech Trefny 2015-08-03 04:21:30 EDT

*** This bug has been marked as a duplicate of bug 1246901 ***

Note You need to log in before you can comment on or make changes to this bug.