Bug 1249282 - binary plugin installation no longer possible
binary plugin installation no longer possible
Status: CLOSED DUPLICATE of bug 1249414
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-01 05:14 EDT by Tomasz Torcz
Modified: 2015-08-13 10:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 10:51:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2015-08-01 05:14:36 EDT
Description of problem:
Some HP printers require closed-source plugin to be installed. The version must match hplip, so after each upgrade user have to run "hp-plugin -i".
Latest version added apparently misguided code preventing running the command as root, thus making installation impossible.

Version-Release number of selected component (if applicable):
hplip-3.15.7-1.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run "hp-plugin -i"
2.
3.

Actual results:
error: hp-plugin should not be run as root/superuser


Expected results:
Plugin should be installed

Additional info:
Comment 1 Jiri Popelka 2015-08-11 07:07:08 EDT
And does it work when you run it as non-root ?

(Also bug #1249414)
Comment 2 Tomasz Torcz 2015-08-11 12:02:27 EDT
It doesn't work as non-root. The behaviour is exactly like in bug#1249414 – if I ssh into the machine and run ”hp-plugin -i” as an user, it hangs during the process.
In process list I see that ”su” is invoked by hp-plugin. But nothing is displayed on screen and no input is working.

My computer is used as a print server. The plugin needs to be installed system-wide. There is no user locally printing on this computer, everything is network-printed via CUPS.
Comment 3 Jiri Popelka 2015-08-13 10:51:32 EDT

*** This bug has been marked as a duplicate of bug 1249414 ***

Note You need to log in before you can comment on or make changes to this bug.