Bug 1249288 - Setting custom certificates require running capsule-certs-generate and capsule-installer
Setting custom certificates require running capsule-certs-generate and capsul...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.0
x86_64 Linux
medium Severity medium (vote)
: GA
: 6.2
Assigned To: Russell Dickenson
Brandi
: Reopened
: 1219641 1361247 1364483 (view as bug list)
Depends On:
Blocks: 1296845
  Show dependency treegraph
 
Reported: 2015-08-01 06:19 EDT by Pavel Moravec
Modified: 2016-11-17 10:17 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:26:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Moravec 2015-08-01 06:19:17 EDT
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html-single/Installation_Guide/index.html#sect-Red_Hat_Satellite-Installation_Guide-Installing_Red_Hat_Satellite_Server-Running_the_Installation_and_Configuration_Program-Other_Configuration_Options


Section Number and Name: 
Procedure 2.6. To Set a Custom Server Certificate after running katello-installer:


Describe the issue: 
When updating SSL certificates on the Satellite, I think capsule certs must be regenerated and capsule updated appropriately. These steps are missing in the procedure.


Suggestions for improvement:
Add step 3 (to re-run capsule-certs-generate on Satellite and to scp the tarball with certificates to all capsules) and step 4 (to re-run capsule-installer on all capsules).

Additional information:
Comment 8 Ivan Necas 2015-08-31 11:09:24 EDT
What about, instead of adding addition steps into the first procedure, linking to the section "6.4.2.1. Configuring Red Hat Satellite Capsule Server with a Custom Server Certificate" and noting that it's needed to do so in case the CA changed.
Comment 21 Ivan Necas 2015-09-17 12:05:49 EDT
Works for me, for the future reviews, it would help to see the diff, when the changes are introduced: it makes the review easier.
Comment 55 Mike McCune 2016-03-28 19:24:30 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 69 Andrew Dahms 2016-08-16 21:48:10 EDT
*** Bug 1361247 has been marked as a duplicate of this bug. ***
Comment 74 Andrew Dahms 2016-10-12 20:43:48 EDT
*** Bug 1219641 has been marked as a duplicate of this bug. ***
Comment 92 Brandi 2016-11-17 10:17:35 EST
*** Bug 1364483 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.