Bug 1249295 - kernel null pointer access prevents system from booting
kernel null pointer access prevents system from booting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-01 07:30 EDT by Thomas Köller
Modified: 2015-10-20 16:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 16:08:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of failed boot attempt (21.36 KB, application/x-xz)
2015-08-01 07:30 EDT, Thomas Köller
no flags Details

  None (edit)
Description Thomas Köller 2015-08-01 07:30:42 EDT
Created attachment 1058276 [details]
Log of failed boot attempt

Description of problem:

After upgrading the kernel package from 4.0.8.fc22.x86_64 to 4.1.3.fc22.x86_64, the system does not boot any more. There appears to be a bug in the dm/raid code that causes a null pointer dereference.


Version-Release number of selected component (if applicable):
kernel 4.1.3.fc22.x86_64

How reproducible:
Always - every attempt to boot fails


Steps to Reproduce:
1. Boot system from grub


Actual results:
Long delay, then rescue shell is opened


Expected results:
System should boot normally

Additional info:
Attached journal
Comment 1 Laura Abbott 2015-08-03 21:24:54 EDT
This looks like https://bugzilla.kernel.org/show_bug.cgi?id=100491. There is a patch listed which fixes the problem to let it boot but it's labeled as a temporary hack. 4.2-rc3 also seems to fix the issue.

I'm MIA this week so evaluation on how to fix this for 4.1.3 is probably going to be delayed. In the mean time, you can try either the given temporary hack patch or booting a rawhide kernel.
Comment 2 Justin M. Forbes 2015-10-20 15:27:33 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.
Comment 3 Thomas Köller 2015-10-20 16:08:59 EDT
Appears to be fixed.

Note You need to log in before you can comment on or make changes to this bug.