Bug 1249315 - [abrt] qt-creator: QScreen::handle() const(): qtcreator killed by SIGSEGV
[abrt] qt-creator: QScreen::handle() const(): qtcreator killed by SIGSEGV
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0f3cb5884218c671f57233132a2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-01 11:03 EDT by Germano Massullo
Modified: 2015-09-18 15:01 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.5.0-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 17:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (88.14 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: core_backtrace (24.89 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: dso_list (26.42 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: environ (1.61 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: maps (128.59 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: mountinfo (3.09 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: open_fds (6.47 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details
File: var_log_messages (297 bytes, text/plain)
2015-08-01 11:03 EDT, Germano Massullo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTCREATORBUG-14838 None None None Never

  None (edit)
Description Germano Massullo 2015-08-01 11:03:02 EDT
Description of problem:
Everytime I try to set a kit I obtain a crash.

Version-Release number of selected component:
qt-creator-3.4.2-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/qtcreator
crash_function: QScreen::handle() const
executable:     /usr/bin/qtcreator
global_pid:     23399
kernel:         4.1.3-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 1 Germano Massullo 2015-08-01 11:03:07 EDT
Created attachment 1058323 [details]
File: backtrace
Comment 2 Germano Massullo 2015-08-01 11:03:08 EDT
Created attachment 1058324 [details]
File: cgroup
Comment 3 Germano Massullo 2015-08-01 11:03:10 EDT
Created attachment 1058325 [details]
File: core_backtrace
Comment 4 Germano Massullo 2015-08-01 11:03:12 EDT
Created attachment 1058326 [details]
File: dso_list
Comment 5 Germano Massullo 2015-08-01 11:03:13 EDT
Created attachment 1058327 [details]
File: environ
Comment 6 Germano Massullo 2015-08-01 11:03:15 EDT
Created attachment 1058328 [details]
File: limits
Comment 7 Germano Massullo 2015-08-01 11:03:17 EDT
Created attachment 1058329 [details]
File: maps
Comment 8 Germano Massullo 2015-08-01 11:03:19 EDT
Created attachment 1058330 [details]
File: mountinfo
Comment 9 Germano Massullo 2015-08-01 11:03:20 EDT
Created attachment 1058331 [details]
File: namespaces
Comment 10 Germano Massullo 2015-08-01 11:03:22 EDT
Created attachment 1058332 [details]
File: open_fds
Comment 11 Germano Massullo 2015-08-01 11:03:23 EDT
Created attachment 1058333 [details]
File: proc_pid_status
Comment 12 Germano Massullo 2015-08-01 11:03:25 EDT
Created attachment 1058334 [details]
File: var_log_messages
Comment 13 Germano Massullo 2015-08-01 11:13:22 EDT
https://bugreports.qt.io/browse/QTCREATORBUG-14838
Comment 14 Germano Massullo 2015-08-01 11:50:15 EDT
Another user experienced a similar problem:

I was interacting with GUI when QTCreator crashed

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/qtcreator
crash_function: QScreen::handle() const
executable:     /usr/bin/qtcreator
global_pid:     29079
kernel:         4.1.3-200.fc22.x86_64
package:        qt-creator-3.4.2-1.fc22
reason:         qtcreator killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Sandro Mani 2015-08-01 14:53:17 EDT
Are you using multiple monitors?
Comment 16 Germano Massullo 2015-08-01 15:03:11 EDT
(In reply to Sandro Mani from comment #15)
> Are you using multiple monitors?

No
Comment 17 Nikolay Semenov 2015-08-17 16:44:00 EDT
There is an update and a possible fix at https://bugreports.qt.io/browse/QTCREATORBUG-14838
Comment 18 Sandro Mani 2015-08-17 17:53:17 EDT
F22 build of qt-creator-3.5.0-rc is here: https://copr.fedoraproject.org/coprs/smani/qt-creator-3.5.0-fc22/, together with https://copr.fedoraproject.org/coprs/dvratil/qt5/ the environment should be as described in the qt bug.
Comment 19 Maxim Prohorenko 2015-08-18 07:13:29 EDT
Another user experienced a similar problem:

Set KDE theme Breeze or Fedora Twenty Two

1. Run qtcreator
2. Tools->Options...
3. Close dialog
4. Tools->Options...
5. 100% Crash

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/qtcreator
crash_function: QScreen::handle() const
executable:     /usr/bin/qtcreator
global_pid:     30310
kernel:         4.1.3-200.fc22.x86_64
package:        qt-creator-3.4.2-1.fc22
reason:         qtcreator killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 20 Sandro Mani 2015-08-18 07:20:12 EDT
Please test with the 3.5.0 build to see whether the issue is indeed fixed there as noted in the upstream report.
Comment 21 Nikolay Semenov 2015-08-20 16:46:51 EDT
First of all, Sandro many thanks for your help!
I have updated qtCreator from a given repo (qt5 update was also installed, but from normal f22 update-repo).
As far as I can see chrash is gone, and also one more bug with qt-designer and *.ui.qml(d.n. I some one have reported it) is also gone (There was a crash of qml interpreter in qt-designer).
Comment 22 Germano Massullo 2015-08-20 16:49:54 EDT
I am not at home at the moment so I cannot provide much details, but I say that last testing version of qt creator is not affected by the problem
Comment 23 Sandro Mani 2015-08-20 17:20:23 EDT
Since qt 5.5 has in the meantime also landed in F22, I'll shortly be pushing the just-released qt-creator 3.5.0 to F22 also, thus based on the feedback the issue should then be fixed.
Comment 24 Fedora Update System 2015-08-24 15:57:48 EDT
qt-creator-3.5.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14159
Comment 25 Fedora Update System 2015-08-24 15:58:05 EDT
qt-creator-3.5.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14160
Comment 26 Fedora Update System 2015-08-24 17:53:58 EDT
qt-creator-3.5.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update qt-creator'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14159
Comment 27 Fedora Update System 2015-08-24 17:56:09 EDT
qt-creator-3.5.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update qt-creator'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14160
Comment 28 Maxim Prohorenko 2015-08-25 05:33:20 EDT
(In reply to Maxim Prohorenko from comment #19)
> Another user experienced a similar problem:
> 
> Set KDE theme Breeze or Fedora Twenty Two
> 
> 1. Run qtcreator
> 2. Tools->Options...
> 3. Close dialog
> 4. Tools->Options...
> 5. 100% Crash
> 
> reporter:       libreport-2.6.2
> backtrace_rating: 4
> cmdline:        /bin/qtcreator
> crash_function: QScreen::handle() const
> executable:     /usr/bin/qtcreator
> global_pid:     30310
> kernel:         4.1.3-200.fc22.x86_64
> package:        qt-creator-3.4.2-1.fc22
> reason:         qtcreator killed by SIGSEGV
> runlevel:       N 5
> type:           CCpp
> uid:            1000

Fixed in 3.5
Comment 29 Fedora Update System 2015-09-16 17:21:30 EDT
qt-creator-3.5.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 30 Fedora Update System 2015-09-18 15:01:48 EDT
qt-creator-3.5.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.