Bug 1249327 - [abrt] ibus: XkbUseExtension(): ibus-ui-gtk3 killed by SIGSEGV
[abrt] ibus: XkbUseExtension(): ibus-ui-gtk3 killed by SIGSEGV
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6cf3031918c31db8b2022a629fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-01 11:52 EDT by madstitz
Modified: 2015-08-13 03:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-02 22:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (47.58 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: core_backtrace (4.30 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: dso_list (8.61 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: environ (3.14 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: maps (39.00 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: mountinfo (4.65 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: open_fds (1.03 KB, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: proc_pid_status (1010 bytes, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details
File: var_log_messages (306 bytes, text/plain)
2015-08-01 11:52 EDT, madstitz
no flags Details

  None (edit)
Description madstitz 2015-08-01 11:52:03 EDT
Version-Release number of selected component:
ibus-1.5.10-5.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: XkbUseExtension
executable:     /usr/libexec/ibus-ui-gtk3
global_pid:     2908
kernel:         4.1.3-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 XkbUseExtension at XKBUse.c:652
 #1 _XkbLoadDpy at XKBBind.c:513
 #2 XKeysymToKeycode at XKBBind.c:157
 #3 keybinding_manager_bind at keybindingmanager.c:210
 #4 panel_keybinding_manager_bind at panel.c:1286
 #5 panel_bind_switch_shortcut at panel.c:1350
 #6 panel_construct at panel.c:683
 #7 panel_new at panel.c:709
 #8 application_bus_name_acquired_cb at application.c:220
 #9 _application_bus_name_acquired_cb_gd_bus_signal_callback at application.c:166
Comment 1 madstitz 2015-08-01 11:52:07 EDT
Created attachment 1058347 [details]
File: backtrace
Comment 2 madstitz 2015-08-01 11:52:08 EDT
Created attachment 1058348 [details]
File: cgroup
Comment 3 madstitz 2015-08-01 11:52:09 EDT
Created attachment 1058349 [details]
File: core_backtrace
Comment 4 madstitz 2015-08-01 11:52:11 EDT
Created attachment 1058350 [details]
File: dso_list
Comment 5 madstitz 2015-08-01 11:52:12 EDT
Created attachment 1058351 [details]
File: environ
Comment 6 madstitz 2015-08-01 11:52:13 EDT
Created attachment 1058352 [details]
File: limits
Comment 7 madstitz 2015-08-01 11:52:15 EDT
Created attachment 1058353 [details]
File: maps
Comment 8 madstitz 2015-08-01 11:52:17 EDT
Created attachment 1058354 [details]
File: mountinfo
Comment 9 madstitz 2015-08-01 11:52:18 EDT
Created attachment 1058355 [details]
File: namespaces
Comment 10 madstitz 2015-08-01 11:52:19 EDT
Created attachment 1058356 [details]
File: open_fds
Comment 11 madstitz 2015-08-01 11:52:21 EDT
Created attachment 1058357 [details]
File: proc_pid_status
Comment 12 madstitz 2015-08-01 11:52:22 EDT
Created attachment 1058358 [details]
File: var_log_messages
Comment 13 fujiwara 2015-08-02 22:24:48 EDT
You don't have to run ibus by your self in GNOME desktop because gnome-settings-daemon runs it without ibus-ui-gtk3.
Comment 14 madstitz 2015-08-12 05:42:50 EDT
I didn't start it, I just received the crash message as I logged into a wayland session on fedora 22.
Comment 15 fujiwara 2015-08-13 00:03:11 EDT
But GNOME Wayland does not launch ibus-ui-gtk3.
Which wayland did you run?
Comment 16 madstitz 2015-08-13 03:10:12 EDT
nevermind, had an entry in my .bashrc that called ibus ;)
thank you for your time. this can be closed.

Note You need to log in before you can comment on or make changes to this bug.