Bug 1249331 - django-compressor bundles cssmin
django-compressor bundles cssmin
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python-django-compressor (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2015-08-01 12:44 EDT by Ville Skyttä
Modified: 2016-08-04 08:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 08:13:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2015-08-01 12:44:15 EDT
django-compressor bundles cssmin which is available as a separate package in Fedora. Patching to use the system one should be straightforward, maybe all that's needed is removal of the bundled cssmin.py, adjusting CSSMinFilter.callback in compressor/filters/cssmin/__init__.py, and adding appropriate python*-cssmin dependencies.

https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#When_a_Bundled_Library_is_Discovered_Post-Review
Comment 1 Jan Kurik 2016-02-24 08:31:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Jonathan Dieter 2016-08-04 08:13:26 EDT
I just looked into this, and it already seems to be fixed (at least in F24+)

Note You need to log in before you can comment on or make changes to this bug.