This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1249424 - Please move iscsi modules to kernel-core
Please move iscsi modules to kernel-core
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 17:14 EDT by Sitsofe Wheeler
Modified: 2015-11-19 07:21 EST (History)
7 users (show)

See Also:
Fixed In Version: kernel-4.2.6-300.fc23 kernel-4.2.6-200.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:57:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2015-08-02 17:14:58 EDT
Description of problem:
At present iscsi initiator modules are in kernel-modules whereas iscsi target modules are in kernel-core. It would be useful if modules such as iscsi_tcp could be moved to kernel-core so as to be available in stripped down virtualisation environments...

Version-Release number of selected component (if applicable):
kernel-core-4.1.3-200.fc22.x86_64

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. rpm -ql kernel-core-4.1.3-200.fc22.x86_64 | grep iscsi_tcp

Actual results:
Nothing.

Expected results:
iscsi_tcp module to be found?

Additional info:
It's not entirely clear how it is decided what will be in kernel-core and kernel-modules. Is adding iscsi initiator pieces a step too far or can it be viewed in a similar way to cifs?
Comment 1 Josh Boyer 2015-08-04 14:23:16 EDT
Specifically, which modules do you want in kernel-core?  Just iscsi_tcp?

IIRC, the target modules are in kernel-core because of something else we need/want in kernel-core requiring them.  If that wasn't the case, they would likely all be in kernel-modules without good reason to keep them in kernel-core.
Comment 2 Sitsofe Wheeler 2015-08-04 14:59:37 EDT
From what I can tell these are the modules I would be after:
iscsi_tcp
libiscsi_tcp
libiscsi
scsi_transport_iscsi

Thanks for the explanation about the target modules.
Comment 3 Sitsofe Wheeler 2015-10-14 06:20:46 EDT
Hi Josh, is there anything more you need from me on this one?
Comment 4 Josh Boyer 2015-10-29 09:36:58 EDT
My apologies for the delay here.  I've moved the modules listed in comment #2 to kernel-core in the rawhide kernels.  I'll discuss moving them in f22/f23 with the team today, but I'm hesitant to do so this late in the release for f22.
Comment 5 Josh Boyer 2015-10-29 11:39:40 EDT
Ok, we've made this change for F23 as well.  F22 is too late in its lifecycle to receive a change like this.
Comment 6 Sitsofe Wheeler 2015-10-31 01:48:14 EDT
Josh:
That's fine - thanks for moving this one forward.
Comment 7 Fedora Update System 2015-11-10 23:15:10 EST
kernel-4.2.6-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-115c302856
Comment 8 Fedora Update System 2015-11-10 23:16:19 EST
kernel-4.2.6-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd94ad8d7c
Comment 9 Fedora Update System 2015-11-11 21:25:14 EST
kernel-4.2.6-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd94ad8d7c
Comment 10 Fedora Update System 2015-11-11 22:58:52 EST
kernel-4.2.6-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-115c302856
Comment 11 Fedora Update System 2015-11-19 04:56:13 EST
kernel-4.2.6-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-11-19 07:21:20 EST
kernel-4.2.6-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.