Bug 1249437 - Errors when issuing gluster volume status command
Errors when issuing gluster volume status command
Status: CLOSED DUPLICATE of bug 1249461
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 21:33 EDT by Con Tassios
Modified: 2015-08-04 23:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-04 23:52:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
etc-glusterfs-glusterd.vol.log 1/3 (14.72 KB, text/plain)
2015-08-04 19:41 EDT, Con Tassios
no flags Details
etc-glusterfs-glusterd.vol.log 2/3 (11.07 KB, text/plain)
2015-08-04 19:42 EDT, Con Tassios
no flags Details
etc-glusterfs-glusterd.vol.log 3/3 (9.03 KB, text/plain)
2015-08-04 19:42 EDT, Con Tassios
no flags Details

  None (edit)
Description Con Tassios 2015-08-02 21:33:18 EDT
Since 3.7.3 I get these errors in etc-glusterfs-glusterd.vol.log when running the command : gluster volume status

[2015-08-03 01:05:01.047641] E [glusterd-op-sm.c:252:glusterd_get_txn_opinfo] (-->/usr/lib64/glusterfs/3.7.3/xlator/mgmt/glusterd.so(glusterd_big_locked_handler+0x30) [0x7f2090e43970] -->/usr/lib64/glusterfs/3.7.3/xlator/mgmt/glusterd.so(__glusterd_handle_stage_op+0x1be) [0x7f2090e455ee] -->/usr/lib64/glusterfs/3.7.3/xlator/mgmt/glusterd.so(glusterd_get_txn_opinfo+0x147) [0x7f2090e566e7] ) 0-management: Unable to get transaction opinfo for transaction ID : 502232c9-36f6-4a9f-bd7f-fe16a63ba44a [Permission denied]
Comment 1 Pranith Kumar K 2015-08-04 08:28:29 EDT
hi Con,
       Could you please add the whole etc-glusterfs-glusterd.vol.log from all the machines in cluster? That should help in finding more about the bug.

Pranith
Comment 2 Con Tassios 2015-08-04 19:41:14 EDT
Created attachment 1059264 [details]
etc-glusterfs-glusterd.vol.log 1/3
Comment 3 Con Tassios 2015-08-04 19:42:07 EDT
Created attachment 1059265 [details]
etc-glusterfs-glusterd.vol.log 2/3
Comment 4 Con Tassios 2015-08-04 19:42:40 EDT
Created attachment 1059266 [details]
etc-glusterfs-glusterd.vol.log 3/3
Comment 5 Con Tassios 2015-08-04 19:43:24 EDT
Logs have been attached for each of 3 cluster members
Comment 6 Atin Mukherjee 2015-08-04 23:52:05 EDT
Functionality wise there is no impact as in the first volume status rpc volume name is not available and for which the txn id is never set and hence the log. BZ 1249461 also tracks the same issue and we already have a patch which is merged mainline and waiting to be backported in 3.7. Given that, I am closing this bug as a duplicate of 1249461

*** This bug has been marked as a duplicate of bug 1249461 ***

Note You need to log in before you can comment on or make changes to this bug.