Bug 1249438 - virt-what does not identify rhev/ovirt
virt-what does not identify rhev/ovirt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-what (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks: 1288337 1301891
  Show dependency treegraph
 
Reported: 2015-08-02 21:47 EDT by Ryan Barry
Modified: 2017-08-01 16:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-what-1.13-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:35:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Add-oVirt-RHBZ-1249438.patch (1.02 KB, patch)
2015-08-03 07:25 EDT, Richard W.M. Jones
no flags Details | Diff

  None (edit)
Description Ryan Barry 2015-08-02 21:47:58 EDT
Description of problem:
virt-what reports ovirt/rhev guests as "kvm" instead of 'ovirt' or 'rhev'

Version-Release number of selected component (if applicable):
virt-what-1.13-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run virt-what in a rhev/ovirt guest
2.
3.

Actual results:
kvm

Expected results:
ovirt (or rhev, as 

Additional info:
This can be checked in dmidecode:
Manufacturer: oVirt
Product Name: oVirt Node

(it's also oVirt Node for the guests)
Comment 2 Richard W.M. Jones 2015-08-03 05:33:00 EDT
It should probably print several facts in this case, eg:

# virt-what
kvm
ovirt
Comment 3 Richard W.M. Jones 2015-08-03 07:25:22 EDT
Created attachment 1058754 [details]
0001-Add-oVirt-RHBZ-1249438.patch

Moving to 7.3 as the development period for 7.2 finished a couple
of weeks ago.

Please try the attached patch, or (perhaps better) give me ssh
access to a Linux VM running on RHEV-H.
Comment 4 Ryan Barry 2016-01-12 11:26:22 EST
(In reply to Richard W.M. Jones from comment #3)
> Created attachment 1058754 [details]
> 0001-Add-oVirt-RHBZ-1249438.patch
> 
> Moving to 7.3 as the development period for 7.2 finished a couple
> of weeks ago.
> 
> Please try the attached patch, or (perhaps better) give me ssh
> access to a Linux VM running on RHEV-H.

This works, but outputs:

ovirt
kvm

It probably also needs:
skip_qemu_kvm=true
Comment 5 Richard W.M. Jones 2016-06-20 08:17:29 EDT
The patch mentioned in comment 3 is upstream:
http://git.annexia.org/?p=virt-what.git;a=commitdiff;h=1159ea3a8e4a65cf56804639498b692740723979
Comment 7 Xianghua Chen 2016-08-22 06:52:25 EDT
Failed with package:
virt-what-1.13-8.el7.x86_64

I have just installed an rhel7.2 guest image on RHEV.
# virt-what
kvm

Shouldn't it output:
kvm
rhev

I have looked into /usr/sbin/virt-what, it only checks for ovirt guest. I saw it is checked by dmidecode, but in rhev guest, the related info:
# dmidecode | grep 'Manufacturer:'
	Manufacturer: Red Hat
	Manufacturer: Red Hat
	Manufacturer: Red Hat
	Manufacturer: Red Hat


The rhel7.3 guest image on rhev for debug(for 1 day):
10.66.8.124
root/redhat
Comment 8 Richard W.M. Jones 2016-08-22 07:33:31 EDT
All Red Hat VMs have "Manufacturer: Red Hat".

A better bet looks like:

        Product Name: RHEV Hypervisor

I have added a commit upstream for this:

http://git.annexia.org/?p=virt-what.git;a=commit;h=73f639241174bde5066838ed67e959ef047da144
Comment 9 Richard W.M. Jones 2016-08-30 08:07:03 EDT
As RHEL 7.3 is in external beta now, I'm moving this to 7.4.
Comment 15 Xianghua Chen 2017-04-25 01:31:56 EDT
Verified with packages:
virt-what-1.13-10.el7.x86_64

Steps:
1. Prepare an ovirt env, install an rhel vm:
# virt-what
ovirt
kvm

2. Prepare a rhv env, install an rhel vm:
# virt-what
rhev
kvm

So verified.
Comment 16 errata-xmlrpc 2017-08-01 16:35:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1952

Note You need to log in before you can comment on or make changes to this bug.