Bug 1249444 - man 7 sched: DESCRIPTION section: description for sched_get_priority_max(2)/sched_get_priority_min(2) swapped
man 7 sched: DESCRIPTION section: description for sched_get_priority_max(2)/s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-pages (Show other bugs)
21
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Nikola Forró
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 22:11 EDT by Sumit Rai
Modified: 2015-08-19 03:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: man-pages-3.69-5.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 03:57:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sumit Rai 2015-08-02 22:11:19 EDT
Description of problem: In manpage sched(7), in "DESCRIPTION" section description for below two functions seems to be swapped i.e. sched_get_priority_max(2) says "Return the minimum priority" and sched_get_priority_min(2) says "Return the maximum priority".

Quote from man 7 sched "DESCRIPTION" section 

"
       sched_get_priority_max(2)
              Return the minimum priority available in a specified scheduling policy.

       sched_get_priority_min(2)
              Return the maximum priority available in a specified scheduling policy.
"

Note: This bug is only found in "man 7 sched", the individual manpages for sched_get_priority_max(2)/sched_get_priority_min(2) gives the right description.

Version-Release number of selected component (if applicable):
man-pages-3.69-4.fc21.noarch

How reproducible: Very.


Steps to Reproduce:
1. On commandline, type "man 7 sched" w/o quotes.
2. Go to "DESCRIPTION" section and scroll down for the description for "sched_get_priority_max(2)/sched_get_priority_min(2)"
Comment 1 Fedora Update System 2015-08-10 10:36:08 EDT
man-pages-4.00-4.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/man-pages-4.00-4.fc23
Comment 2 Fedora Update System 2015-08-10 10:36:38 EDT
man-pages-3.81-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/man-pages-3.81-3.fc22
Comment 3 Fedora Update System 2015-08-10 10:38:27 EDT
man-pages-3.69-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/man-pages-3.69-5.fc21
Comment 5 Fedora Update System 2015-08-10 22:12:54 EDT
Package man-pages-3.69-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-pages-3.69-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13174/man-pages-3.69-5.fc21
then log in and leave karma (feedback).
Comment 6 Sumit Rai 2015-08-12 21:51:49 EDT
Verified the fix: works for me. I have also updated karma. - Thanks.
Comment 7 Fedora Update System 2015-08-13 12:59:44 EDT
man-pages-3.81-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-08-14 22:15:47 EDT
man-pages-4.00-4.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-08-19 03:57:21 EDT
man-pages-3.69-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.