Bug 1249460 - inventory shows 0000:0000 for USB root hubs on HP rx1620
inventory shows 0000:0000 for USB root hubs on HP rx1620
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: inventory (Show other bugs)
21
Unspecified Unspecified
unspecified Severity low (vote)
: 21.1
: ---
Assigned To: Dan Callaghan
tools-bugs
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 00:20 EDT by Dan Callaghan
Modified: 2015-10-20 23:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 23:25:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-08-03 00:20:44 EDT
Need to figure out if there really is no USBIDs for these devices (are they just emulated/virtual perhaps?). Either fix lshw to report the USBIDs properly or make beaker-system-scan exclude 0000:0000 from USBID key-value.
Comment 2 Dan Callaghan 2015-08-17 01:06:33 EDT
The USB root hubs are essentially virtual, they seem to be an abstraction created by the kernel to manage all the USB devices attached to a PCI USB host controller.

In newer kernels they have a USB id like 1d6b:0001, but in the RHEL5 kernel the vendor and product really are hardcoded as zeroes instead:

https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/tree/drivers/usb/core/hcd.c?id=refs/tags/v2.6.18#n119

It's possible that beaker-system-scan (or lshw?) should just be filtering out these root hubs which are not real devices. I'm not sure if that's the best answer or not. It probably doesn't hurt to include them as we are now.

It looks like we should just make beaker-system-scan leave out USB devices from the USBID key when the ids are all zeroes as in this case.
Comment 3 Dan Callaghan 2015-08-17 01:23:33 EDT
http://gerrit.beaker-project.org/4352
Comment 6 Dan Callaghan 2015-10-20 23:25:19 EDT
Beaker 21.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.