Bug 1249506 - 3 upstream tests failed
3 upstream tests failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gstreamer1-plugins-base (Show other bugs)
7.2
ppc64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks: 1265905
  Show dependency treegraph
 
Reported: 2015-08-03 04:13 EDT by Tomas Pelka
Modified: 2015-11-19 02:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1265905 (view as bug list)
Environment:
Last Closed: 2015-11-19 02:05:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2015-08-03 04:13:33 EDT
Description of problem:
Following tests failed for ppc64
FAIL: elements/playbin-complex
FAIL: libs/libsabi
FAIL: elements/adder

Version-Release number of selected component (if applicable):
gstreamer1-plugins-base-1.4.5-1.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2015/07/10343/1034320/2118750/32903939/TESTOUT.log
Comment 1 Tomas Pelka 2015-08-03 04:14:46 EDT
For ppc64le there are only 2 failures:
FAIL: elements/videoscale
FAIL: libs/libsabi

Log at http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2015/07/10343/1034320/2118751/32903947/TESTOUT.log
Comment 2 Tomas Pelka 2015-08-03 05:44:50 EDT
On x86_64 there is just on failure:
FAIL: elements/adder

http://lab-02.rhts.eng.bos.redhat.com/beaker/logs/tasks/32983+/32983869/TESTOUT.log
Comment 3 Tomas Pelka 2015-08-03 09:58:49 EDT
s390x results - 3 failures:

FAIL: elements/adder
FAIL: elements/playbin-complex
FAIL: elements/videoscale
Comment 4 Wim Taymans 2015-08-04 02:56:12 EDT
Is it possible to give a login to the machine with the problem to further debug this?
Comment 5 Vadim Rutkovsky 2015-08-04 05:19:50 EDT
It looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1234325 - it should be reopened
Comment 6 Wim Taymans 2015-09-07 07:28:33 EDT
elements/adder and elements/playbin-complex are cause by endiannes bug in the unit test. I have a fix for those.

elements/videoscale causes a segfault in the ORC emulation code. There are really 2 problems:

1) should not segfault, I think I have an idea what might be wrong, it's not setting up the parameters for the emulated function correctly on big endian

2) it should really use the backup function (which works fine)

running the test with ORC_CODE=backup like this makes it work (run in tests/check):

ORC_CODE=backup make elements/videoscale.check

We should probably fix 2) for rhel7.2, it's not a complicated fix and would in practice avoid hitting bug 1). for 1) I would need some more testing.
Comment 7 Wim Taymans 2015-09-07 11:33:48 EDT
I added new ORC and gstreamer1-plugins-base to the errata with fixes for all the issues.
Comment 9 Tomas Pelka 2015-09-23 14:48:05 EDT
gstreamer1-plugins-base-1.4.5-2.el7


on s390x:

# TOTAL: 64
# PASS:  64

------------
ppc64:

# TOTAL: 64
# PASS:  63
# SKIP:  0
# XFAIL: 0
# FAIL:  1

FAIL: libs/libsabi

full log at http://lab-02.rhts.eng.brq.redhat.com/beaker/logs/tasks/34570+/34570474/gstreamer1-plugins-base.log

-----------
ppc64le

# TOTAL: 64
# PASS:  63
# SKIP:  0
# XFAIL: 0
# FAIL:  1

FAIL: libs/libsabi

full log at http://lab-02.rhts.eng.bos.redhat.com/beaker/logs/tasks/34570+/34570478/gstreamer1-plugins-base.log

I guess anothter issue, right?
Comment 10 Tomas Pelka 2015-09-24 02:58:02 EDT
I'm going to file the FAIL: libs/libsabi as separated bug.
Comment 11 errata-xmlrpc 2015-11-19 02:05:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2221.html

Note You need to log in before you can comment on or make changes to this bug.