This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1249516 - Some Designer features unavailable after JBDS restart (TeiidServerManager is being used before it has been initialised)
Some Designer features unavailable after JBDS restart (TeiidServerManager is ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity urgent
: ---
: 6.2.0
Assigned To: Barry LaFond
Andrej Smigala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 04:45 EDT by Andrej Smigala
Modified: 2015-11-17 13:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 13:08:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eclipse log (62.16 KB, text/plain)
2015-08-03 04:45 EDT, Andrej Smigala
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2597 Blocker Closed Some Designer features unavailable after JBDS restart (TeiidServerManager is being used before it has been initialised) 2015-11-30 10:35 EST

  None (edit)
Description Andrej Smigala 2015-08-03 04:45:49 EDT
Created attachment 1058669 [details]
eclipse log

After restarting JBDS, some features of designer are missing (see steps to reproduce).

The error seems to be

    Programming error: The TeiidServerManager is being used before it has been initialised

(full log attached)



Steps to reproduce:
# start JBDS, select a new workspaces, switch to Teiid Designer perspective
# create new model project
# create a source model, add a table
# close JBDS
# open JBDS again
# right click the source model, go to New Child
# notice the only available options are Index and Custom diagram (no Table, Procedure etc.)
Comment 2 JBoss JIRA Server 2015-08-06 13:32:00 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2597 to Resolved
Comment 3 JBoss JIRA Server 2015-08-12 07:13:26 EDT
Andrej Šmigala <asmigala@redhat.com> updated the status of jira TEIIDDES-2597 to Closed
Comment 4 Andrej Smigala 2015-08-12 07:14:20 EDT
Can no longer reproduce with jbds-is 8.0.3 CR2. However, found a new issue that might be related: TEIIDDES-2608.
Comment 5 JBoss JIRA Server 2015-09-11 15:33:01 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2597 to Reopened
Comment 6 JBoss JIRA Server 2015-09-11 15:37:38 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2597 to Resolved
Comment 7 JBoss JIRA Server 2015-10-14 03:23:10 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2597 to Closed

Note You need to log in before you can comment on or make changes to this bug.