Bug 124956 - mksf.ext3 -T largefile -> floating point error
mksf.ext3 -T largefile -> floating point error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 12:16 EDT by l ciani
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 13:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description l ciani 2004-06-01 12:16:35 EDT
Description of problem: 
I have deleted all windows partition from my second hard-drive 
(/dev/hdb) using fdisk. None of the partitions of that disk were 
mounted, obviously. 
I have then created one single linux partition on that disk, again 
with fdisk. 
Finally I invoked /sbin/mkfs.ext3 -T largefile /dev/hdb1 
I have used the -T switch because I am going to use this drive to 
edit large video files. 
I was greeted by the following message: 
[root@mysystem]# /sbin/mkfs.ext3 -T largefile /dev/hdb1 
mke2fs 1.34 (25-Jul-2003) 
Errore di virgola mobile 
(that's Italian for "Floating point error") 
 
 
 
Version-Release number of selected component (if applicable): 
util-linux-2.11y-29 
 
 
How reproducible: 
For instance, run "mkfs.ext3 -T largefile /dev/newly-formatted-drive" 
 
Steps to Reproduce: 
1. format a hard-disk on /dev/hdb (mine is a 20GB Quantum Fireball 
Lct10) 
2. create a single linux partition 
3. run mkfs.ext3 -T largefile /dev/hdb1 
   
Actual results: 
[root@mysystem]# /sbin/mkfs.ext3 -T largefile /dev/hdb1 
mke2fs 1.34 (25-Jul-2003) 
Errore di virgola mobile 
 
 
Expected results: 
No error messages 
 
Additional info: 
I succesfully formated the drive omitting the -T largefile parameter.
Comment 1 Elliot Lee 2004-06-02 13:18:09 EDT
Please try FC2. I can't reproduce the bug with the e2fsprogs included
in it.

Note You need to log in before you can comment on or make changes to this bug.