Bug 1249567 - Add or Remove input variables for WS operation not working correctly [NEEDINFO]
Add or Remove input variables for WS operation not working correctly
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Barry LaFond
Andrej Smigala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 06:26 EDT by Andrej Smigala
Modified: 2016-02-05 03:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the user edits a web service model, clicking Add or Remove variables shows the Edit Input Variables editor with all the variables deselected. Selecting some of the variables adds them to the transformation, resulting in invalid SQL.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 03:35:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
blafond: needinfo? (asmigala)
blafond: needinfo? (asmigala)
blafond: needinfo? (asmigala)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2523 Minor Reopened Add or Remove input variables for WS operation not working correctly 2016-08-09 01:30 EDT

  None (edit)
Description Andrej Smigala 2015-08-03 06:26:41 EDT
When editing a web service model, clicking Add or Remove variables shows the Edit Input Variables editor with all the variables deselected. Selecting some of the variables adds them to the transformation, resulting in invalid SQL.

Steps to reproduce:

# import the attached project
# double click the OrderCheckingWs in model explorer, the model editor will open
# click Add or Remove variables
# notice all variables are deselected
# select OrderDate, click OK
# save the model, the following validation error is shown:

ERROR: Variable VARIABLES.IN_OrderDate was previously declared.


Note that as a user checks/unchecks variables, the SQL transformation is trying to keep pace with the selections and isn't staying in sync. You can end up with multiple/duplicates. Expanding the tree shows that 2 of the 3 variables show as checked. But OrderDate is Not.
Comment 2 Barry LaFond 2015-08-07 09:35:41 EDT
Pushing to 9.0.4. Need more info to determine circumstances of the issue.
Comment 3 Barry LaFond 2015-09-10 12:48:44 EDT
pushing to next release.
Comment 4 Matus Makovy 2016-02-05 03:35:41 EST
Closing this since we are tracking issues for tooling only in JIRA from now on.

Note You need to log in before you can comment on or make changes to this bug.