Bug 1249575 - Could you update the package to the current upstream version?
Could you update the package to the current upstream version?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 06:50 EDT by Sascha Zantis
Modified: 2015-08-14 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: rrdtool-1.5.3-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:10:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sascha Zantis 2015-08-03 06:50:06 EDT
Description of problem:
rrdtool in F22 repos is 1.4.9, current upstream is 1.5.3
There is a new feature which I really like that is not supported by 1.4.9 (adding RRA via rrdtool tune command, see https://oss.oetiker.ch/rrdtool/doc/rrdtune.en.html.

Example: rrdtool tune some.rrd RRA:AVERAGE:0.5:268:10

I built it from source from now, because the specfile contains a few patches and I don't know how to configure it for 1.5.3.

Regards, Sascha
Comment 1 Jaroslav Škarvada 2015-08-03 12:25:52 EDT
It is in f23+.

It seems to be API/ABI compatible and not breaking other deps, thus trying to get it into f22 updates-testing and if nothing breaks to f22 stable (later).
Comment 2 Fedora Update System 2015-08-03 18:22:45 EDT
rrdtool-1.5.3-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rrdtool-1.5.3-4.fc22
Comment 3 Fedora Update System 2015-08-05 18:28:55 EDT
Package rrdtool-1.5.3-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rrdtool-1.5.3-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12815/rrdtool-1.5.3-4.fc22
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2015-08-14 22:10:08 EDT
rrdtool-1.5.3-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.