This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1249610 - [RFE] add alias for transparent_hugepages
[RFE] add alias for transparent_hugepages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: FutureFeature, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 08:01 EDT by Tereza Cerna
Modified: 2016-11-04 03:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: tuned-2.7.0-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:23:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tereza Cerna 2015-08-03 08:01:48 EDT
There "transparent_hugepage" is in /etc/default/grub

# cat /etc/default/grub | grep GRUB_CMDLINE_LINUX=
GRUB_CMDLINE_LINUX="console=tty0 elevator=noop crashkernel=auto rd.lvm.lv=rhel_sheep-6/root rd.lvm.lv=rhel_sheep-6/swap console=ttyS0 transparent_hugepage=never"

and "transparent_hugepages" in /usr/lib/tuned/*/tuned.conf

# grep -ri transparent /usr/lib/tuned/*/tuned.conf 
/usr/lib/tuned/network-latency/tuned.conf:transparent_hugepages=never
/usr/lib/tuned/oracle/tuned.conf:transparent_hugepages=never

I think that it is confusing. Please add alias for transparent_hugepages into tuned.
Comment 3 Jaroslav Škarvada 2016-07-18 10:29:10 EDT
Fixed by the following upstream commit:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=cf8f326c44ac2693531de5c9dba146a783a29943
Comment 5 Tereza Cerna 2016-08-19 05:16:25 EDT
============================
Verified in:
    tuned-2.7.1-2.el7.noarch
PASS
============================

# cat /etc/tuned/testprofile1/tuned.conf
[vm]
transparent_hugepage=never
# tuned-adm profile testprofile1
# cat /sys/kernel/mm/transparent_hugepage/enabled
always madvise [never]

# cat /etc/tuned/testprofile2/tuned.conf
[vm]
transparent_hugepages=never
# tuned-adm profile testprofile2
# cat /sys/kernel/mm/transparent_hugepage/enabled
always madvise [never]

============================
Reproduced in:
    tuned-2.5.1-4.el7.noarch
FAIL
============================

# cat /etc/tuned/testprofile1/tuned.conf
[vm]
transparent_hugepage=never
# tuned-adm profile testprofile1
# cat /sys/kernel/mm/transparent_hugepage/enabled
[always] madvise never                                >>>> FAIL

# cat /etc/tuned/testprofile2/tuned.conf
[vm]
transparent_hugepages=never
# tuned-adm profile testprofile2
# cat /sys/kernel/mm/transparent_hugepage/enabled
always madvise [never]
Comment 7 errata-xmlrpc 2016-11-04 03:23:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html

Note You need to log in before you can comment on or make changes to this bug.