Bug 1249624 - vdsCli fails parsing connectStorageDmain arguments is the user provide an empty iSCSI password
vdsCli fails parsing connectStorageDmain arguments is the user provide an emp...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-rc
: 4.17.9
Assigned To: Piotr Kliczewski
Jiri Belka
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 08:36 EDT by Simone Tiraboschi
Modified: 2016-01-19 10:35 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 10:35:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
vdsm.log (20.90 KB, text/plain)
2015-09-04 10:07 EDT, Simone Tiraboschi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46133 master MERGED vdsClient: parse no value arguments Never
oVirt gerrit 46511 ovirt-3.6 MERGED vdsClient: parse no value arguments Never

  None (edit)
Description Simone Tiraboschi 2015-08-03 08:36:26 EDT
Description of problem:
[root@voodoo6 ~]# vdsClient -s 0 connectStorageServer "3"
"00000000-0000-0000-0000-000000000000"
"connection=192.168.1.125,iqn=iqn.2015-03.com.redhat:simone1,portal=1,user=user,password=password,id=2c5c5f35-e203-42bf-b0b6-1954150e88b4,port=3260"

Got correctly parsed.

While
[root@c71heis10731 ~]# vdsClient -s 0 connectStorageServer "3"
"00000000-0000-0000-0000-000000000000"
"connection=192.168.1.125,iqn=iqn.2015-03.com.redhat:simone1,portal=1,user=,password=,id=2c5c5f35-e203-42bf-b0b6-1954150e88b4,port=3260"
Error storage server connection: ("domType=3,
spUUID=00000000-0000-0000-0000-000000000000,
conList=[{'2c5c5f35-e203-42bf-b0b6-1954150e88b4': 'port',
'connection': '192.168.1.125', 'iqn':
'iqn.2015-03.com.redhat:simone1', 'portal': '1', 'user': ',', '=':
'id'}]",)
is not:
 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. run vdsClient connectStorageServer trying to connect an iSCSI device without using a password
2.
3.

Actual results:
It correctly parses the argument list.

Expected results:
',' is used for the user and 'id' as the value of a key called '='.

Additional info:
Till 3.5.4 the same sequence was working.
Comment 1 Allon Mureinik 2015-08-03 09:03:17 EDT
Seems that this regression was introduced by 00cae320514b096c11bfb7b48ebe944235b2e85a (vdsClient: alternative ways to provide password)
Comment 2 Piotr Kliczewski 2015-09-04 09:43:04 EDT
Please provide vdsm log.
Comment 3 Simone Tiraboschi 2015-09-04 10:07:37 EDT
Created attachment 1070283 [details]
vdsm.log
Comment 4 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:45 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-18 04:33:52 EDT
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 6 Jiri Belka 2016-01-15 12:40:26 EST
ok, vdsm-cli-4.17.17-0.el7ev.noarch

[root@dell-r210ii-04 slowfs]# vdsClient -s 0 connectStorageServer "3" "00000001-0001-0001-0001-0000000003e1" "connection=10.34.63.202,iqn.2016-01-06.brq.str-01:jbelka-test,portal=1,user=,password=,id=bf87244f-198d-4876-8aa3-6c94d079c135,port=3260"

[root@dell-r210ii-04 slowfs]# echo $?
0

Note You need to log in before you can comment on or make changes to this bug.