Bug 124965 - System hangs with cdrecord, SG_IO and scsi cdwriter
System hangs with cdrecord, SG_IO and scsi cdwriter
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 12:52 EDT by Adam Bowns
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version: FC3 - kernel-2.6.9-1.681_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 20:29:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (10.57 KB, text/plain)
2004-06-01 13:22 EDT, Adam Bowns
no flags Details
cat /proc/scsi/scsi (492 bytes, text/plain)
2004-06-01 13:23 EDT, Adam Bowns
no flags Details

  None (edit)
Description Adam Bowns 2004-06-01 12:52:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
cdrecord hangs system at the stage

"Blanking PMA, TOC, pregap"

and again at the stage

"Fixating..."

At these stages the whole system hangs for about 30 seconds, then
resumes normal operation. I have a scsi cdwriter and I am using

cdrecord -v speed=4 dev=/dev/cdrom1 blank=fast filename.iso

to execute cdrecord. On previous versions before the introduction of
SG_IO I never had this problem.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1. cdrecord -v speed=4 dev=/dev/cdrom1 blank=fast filename.iso

Actual Results:  system hangs, then resumes about 30 seconds later.

Expected Results:  no hang.

Additional info:
Comment 1 Arjan van de Ven 2004-06-01 13:00:28 EDT
which scsi controller is this ? which burner ?
Comment 2 Arjan van de Ven 2004-06-01 13:06:28 EDT
can you attach the output of "cat /proc/scsi/scsi" and of dmesg ?
Comment 3 Adam Bowns 2004-06-01 13:22:39 EDT
Created attachment 100752 [details]
dmesg
Comment 4 Adam Bowns 2004-06-01 13:23:21 EDT
Created attachment 100753 [details]
cat /proc/scsi/scsi
Comment 5 Adam Bowns 2004-06-01 13:23:56 EDT
Scsi controller is Adaptec 19160 using module aic7xxx.

The burner is a Yamaha CRW2100S
Comment 6 giulioo 2004-06-01 16:25:20 EDT
Try adding
 -immed
to the cdrecord command line options

Comment 7 Adam Bowns 2004-06-01 16:58:05 EDT
I tried it with the -immed option and it has fixed the problem, I got
a slight jump on audio playback at the “fixating...” stage, but no
system hangs, which is good enough for me :-)

I've done a little bit of reading about IMMED and found that it is
used to stop a device using all the bandwidth of the bus it is on. I
would understand why this would fix my problem if my hard disk and my
cd-writer were on the same bus but they are on 2 separate buses, with
2 separate cables. My hard disk is on the U160 bus, with its own 68pin
cable. And My cd-writer is on another bus (don't know which scsi
version it is, but it's on its own 50pin cable).

Do you have any idea's why this fixes my problem ?

Also do you know why this problem has only arisen since the
introduction of SG_IO ?
Comment 8 Adam Bowns 2004-11-23 20:29:28 EST
This problem has been totally fixed since I upgraded to FC3
(kernel-2.6.9-1.681_FC3), I'm not even getting the slight jump on
audio playback anymore.

Note You need to log in before you can comment on or make changes to this bug.