This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1249708 - postgresql-9.4.4-3.fc24 FTBFS: Installed (but unpackaged) file(s) with rpm-4.13
postgresql-9.4.4-3.fc24 FTBFS: Installed (but unpackaged) file(s) with rpm-4.13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 11:33 EDT by Petr Pisar
Modified: 2015-10-04 15:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: postgresql-9.4.4-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 15:15:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-08-03 11:33:10 EDT
postgresql-9.4.4-3.fc24 fails to build in F24:

Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/postgresql-9.4.4-3.fc24.i386
error: Installed (but unpackaged) file(s) found:
   /usr/share/doc/postgresql/README.rpm-dist
    Macro expanded in comment on line 216: # We require this to be present for %%{_prefix}/lib/tmpfiles.d
    Macro expanded in comment on line 222: # This is actually needed for the %%triggerun script but Requires(triggerun)
    Macro expanded in comment on line 223: # is not valid.  We can use post because this particular %%triggerun script
    Macro expanded in comment on line 229: # postgresql-server(:MODULE_COMPAT_%%{postgresql_major}).
    Installed (but unpackaged) file(s) found:
   /usr/share/doc/postgresql/README.rpm-dist

Difference between working and failing build root:

        kernel-headers 	4.2.0-0.rc3.git3.1.... 	> 	4.2.0-0.rc3.git4.1....
	dnf-conf 	1.0.2-2.fc24 	< 	
	python3-iniparse 	0.4-16.fc23 	< 	
	python3-dnf-plugins-core 	0.1.9-1.fc23 	< 	
	rpm-build 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	dnf-plugins-core 	0.1.9-1.fc23 	< 	
	rpm-libs 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	librepo 	1.7.16-2.fc23 	< 	
	hawkey 	0.5.9-2.fc24 	< 	
	python3-six 	1.9.0-3.fc23 	< 	
	bash-completion 	1:2.1-8.20150513git... 	< 	
	libreport-filesystem 	2.6.2-2.fc24 	< 	
	python3-pygpgme 	0.3-12.fc22 	< 	
	rpm-python3 	4.12.0.1-18.fc24 	< 	
	rpm-plugin-systemd-inhibit 	4.12.0.1-18.fc24 	< 	
	python3-dnf 	1.0.2-2.fc24 	< 	
	libsolv 	0.6.11-1.fc23 	< 	
	python3-libcomps 	0.1.6-14.fc22 	< 	
	rpm-plugin-selinux 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	gpgme 	1.4.3-6.fc23 	< 	
	rpm 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	rpm-build-libs 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	deltarpm 	3.6-10.fc23 	< 	
	python3-hawkey 	0.5.9-2.fc24 	< 	
	python3-librepo 	1.7.16-2.fc23 	< 	
	libcomps 	0.1.6-14.fc22 	<
Comment 1 Pavel Raiskup 2015-08-04 07:10:04 EDT
> FTBFS: Installed (but unpackaged) file(s) with rpm-4.13

TBH, I don't know why README.rpm-dist was installed by %files before.

Relevant commit:
http://pkgs.fedoraproject.org/cgit/postgresql.git/commit/?id=a037a895022d3f
Comment 2 Fedora Update System 2015-09-25 09:49:25 EDT
postgresql-9.4.4-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ba6b14d36d
Comment 3 Fedora Update System 2015-09-26 20:54:52 EDT
postgresql-9.4.4-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update postgresql'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ba6b14d36d
Comment 4 Fedora Update System 2015-10-04 15:15:34 EDT
postgresql-9.4.4-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.