Bug 1249731 - Serious rendering issues in nightly RHEL-7.2 build
Summary: Serious rendering issues in nightly RHEL-7.2 build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-03 16:29 UTC by Jonathon Jongsma
Modified: 2015-11-19 04:27 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-server-1.17.2-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 04:27:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing an example of the rendering issue. (57.66 KB, image/png)
2015-08-03 16:29 UTC, Jonathon Jongsma
no flags Details
screencast of the problem (4.14 MB, application/ogg)
2015-08-04 09:45 UTC, Pavel Grunt
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2198 normal SHIPPED_LIVE Xorg server and driver bug fix and enhancement update 2015-11-19 08:04:34 UTC

Description Jonathon Jongsma 2015-08-03 16:29:08 UTC
Created attachment 1058798 [details]
Screenshot showing an example of the rendering issue.

I installed the nightly version of rhel-7.2 to test something, and it was almost unusable because large areas of the screen were black, and the display was very flickery (sometimes displaying background images on top of foreground windows). 

I'm testing this in a vm, but I am able to reproduce this with both VNC and Spice, and I am also able to reproduce with both the "QXL" driver and the "VGA" driver. 

My colleague Pavel Grunt (CCed) verified that it also happened on his machine and said that the behavior started when upgrading from xorg-x11-server-Xorg-1.17.2-3.el7.x86_64 to xorg-x11-server-Xorg-1.17.2-4.el7.x86_64. But he also suggested that the issue does not occur when using xfce with the new X server.

Comment 1 Pavel Grunt 2015-08-04 09:45:05 UTC
Created attachment 1058995 [details]
screencast of the problem

old images are showing up

Comment 2 Pavel Grunt 2015-08-04 09:45:52 UTC
As Jonathon mentioned downgrading to 
 xorg-x11-server-common-1.17.2-3.el7.x86_64.rpm
 xorg-x11-server-Xorg-1.17.2-3.el7.x86_64.rpm
avoids the problem

Comment 3 Ray Strode [halfline] 2015-08-04 21:25:51 UTC
chatted with ajax about this and we debugged it.  Patch needs to unconditionally disable GLX_MESA_copy_sub_buffer

Comment 5 Ray Strode [halfline] 2015-08-05 14:48:00 UTC
s/disable/enable/ above

Comment 9 errata-xmlrpc 2015-11-19 04:27:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html


Note You need to log in before you can comment on or make changes to this bug.