Bug 124976 - Ant calls javac, javac cannot find some basic j2sdk classes
Ant calls javac, javac cannot find some basic j2sdk classes
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
http://linuxhelp.homeunix.com/cgi-bin...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 14:51 EDT by ahmet sevki
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 07:30:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ahmet sevki 2004-06-01 14:51:15 EDT
version:
ant-1.5.2-26 (the one that comes with release iso's of fedora core 2)

I downloaded JBother, which is a jabber client. I ran ant on build.xml
file, and it gave compile errors complaining it can not find some
classes (e.g. JText, classes in swing package) that are already in
J2SDK. (version 1.4.02) These packages that the java compiler
complained about not finding are already in j2sdk libraries (I opened
src.zip from j2sdk, and verified that they are there, we are talking
about basic swing components, javax.sound classes )

then I went and downloaded ant 1.6 from the apache website it worked
fine. Also I ran it with the 1.5 version that I got from the apache
website, and it was also working.

The best way to reproduce:

the address for JBother (an open source app)
http://linuxhelp.homeunix.com/cgi-bin/rblh/index.rb?handler=downloads&d=jbother

and using the cvs commands, download the source:

CVS Access
You can download the latest development snapshot via anonymous CVS. Type: 

cvs -d ":pserver:anonymous@valhalla.dydns.com:/usr/local/cvs" login 

Just hit enter when it ask for a password. Then type:

cvs -d ":pserver:anonymous@valhalla.dydns.com:/usr/local/cvs" co JBother 

To download the latest source. 

go into directory and type ant. If you have fedora core installed ant
(the rpm) it will give errors about not finding j2sdk base classes. 
go and download from ant.apache.org site, set ant_home etc. it works fine.
Comment 1 Michael 2004-09-05 23:51:12 EDT
I think this is a bug with the gcj-compiled version of ant that is in
/usr/bin/ant in FC2. 

Problem will go away if one relinks classic-ant to be ant:

su -
cd /usr/bin
mv ant gcj-ant
ln -s classic-ant ant

Behavior when compiling jmol source (www.jmol.org) is the same as
reported above. Random classes in javax.swing.text are reported as
missing in the import statements. If you rearrange the import
statements then the *missing* classes change/move around. 

My platform is amd64. At first I thought it was a problem with sun
jdk-1.5.0-rc-linux-amd64. But I found the same problem with
j2sdk-1.4.2 ... the 32 bit version. 

Relink as above and your problem will go away. 

Miguel
Comment 2 Gary Benson 2004-09-08 07:30:02 EDT
Sounds like the problem is caused by missing classes.  I'm going to
defer this, since a) you have a workaround, and b) ant will be
arranged differently in FC3.

Note You need to log in before you can comment on or make changes to this bug.