Bug 1249867 - [WHQL][vioscsi]Job hangs and it cannot continure on windows2008 guest via WLK
[WHQL][vioscsi]Job hangs and it cannot continure on windows2008 guest via WLK
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks: 1288337
  Show dependency treegraph
 
Reported: 2015-08-03 22:33 EDT by Min Deng
Modified: 2016-11-04 04:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:48:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshotandlog (410.14 KB, application/x-gzip)
2015-08-03 22:33 EDT, Min Deng
no flags Details

  None (edit)
Description Min Deng 2015-08-03 22:33:02 EDT
Created attachment 1058917 [details]
screenshotandlog

Description of problem:
Job hangs and it cannot continure on windows2008 guest via WLK 
Version-Release number of selected component (if applicable):
kernel-3.10.0-300.el7.x86_64
qemu-kvm-rhev-2.3.0-13.el7.x86_64
virtio-win-prehwhql-0.1-108
How reproducible:
5times

Steps to Reproduce:
1.boot up guest with the following cli
   /usr/libexec/qemu-kvm -name 108SCS20083258E -enable-kvm -m 4G -smp 4 -uuid 644aa24a-457a-4995-af91-1bc275035ee8 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/108SCS20083258E,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=108SCS20083258E,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x86_dvd_342333.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=108SCS20083258E.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:7d:24:fe:87,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7,num_queues=4 -drive file=108SCS20083258E_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0

or 

/usr/libexec/qemu-kvm -name 108SCS200864VQQ -enable-kvm -m 4G -smp 4 -uuid e044e546-cc5f-4baf-9f95-5db6786391a3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/108SCS200864VQQ,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=108SCS200864VQQ,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=108SCS200864VQQ.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:66:31:1e:7b,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7,num_queues=4 -drive file=108SCS200864VQQ_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0
2.submit the job
  For example,
  Syscache Test -
  Read capacity 16 UNIT Test - SCSI Complaince Test (LOGO) -
3.

Actual results:
They neither failed nor passed,the rest jobs could not be tested either.

Expected results:
They can pass.

Additional info:
QE will provide screenshot and log to the bug later
Comment 3 Min Deng 2015-08-04 03:33:12 EDT
Modify "-smp 4,cores=4"  the jobs could continue and will update bug continuously
in accordance with jobs' status.Any issues please let me know,thanks !

Best Regards
Min
Comment 4 Min Deng 2015-08-06 03:43:15 EDT
(In reply to dengmin from comment #3)
> Modify "-smp 4,cores=4"  the jobs could continue and will update bug
> continuously
> in accordance with jobs' status.Any issues please let me know,thanks !
> 
> Best Regards
> Min
  Fortunately,the rest jobs could not continue even if QE stop previous job manually.To be honest,it likes zombie process.
Comment 5 Min Deng 2015-08-11 22:46:59 EDT
(In reply to dengmin from comment #4)
> (In reply to dengmin from comment #3)
> > Modify "-smp 4,cores=4"  the jobs could continue and will update bug
> > continuously
> > in accordance with jobs' status.Any issues please let me know,thanks !
> > 
> > Best Regards
> > Min
>   Fortunately,the rest jobs could not continue even if QE stop previous job
> manually.To be honest,it likes zombie process.

  The issue could be reoproduced on build 109,please double check it,thanks !
Comment 6 Vadim Rozenfeld 2015-08-12 03:54:42 EDT
(In reply to dengmin from comment #5)
> (In reply to dengmin from comment #4)
> > (In reply to dengmin from comment #3)
> > > Modify "-smp 4,cores=4"  the jobs could continue and will update bug
> > > continuously
> > > in accordance with jobs' status.Any issues please let me know,thanks !
> > > 
> > > Best Regards
> > > Min
> >   Fortunately,the rest jobs could not continue even if QE stop previous job
> > manually.To be honest,it likes zombie process.
> 
>   The issue could be reoproduced on build 109,please double check it,thanks !

Hi Min,

Can we pass the test when switching to single queue mode (num_queues=1) ?

Thanks,
Vadim.
Comment 7 Min Deng 2015-08-12 04:08:25 EDT
(In reply to Vadim Rozenfeld from comment #6)
> (In reply to dengmin from comment #5)
> > (In reply to dengmin from comment #4)
> > > (In reply to dengmin from comment #3)
> > > > Modify "-smp 4,cores=4"  the jobs could continue and will update bug
> > > > continuously
> > > > in accordance with jobs' status.Any issues please let me know,thanks !
> > > > 
> > > > Best Regards
> > > > Min
> > >   Fortunately,the rest jobs could not continue even if QE stop previous job
> > > manually.To be honest,it likes zombie process.
> > 
> >   The issue could be reoproduced on build 109,please double check it,thanks !
> 
> Hi Min,
> 
> Can we pass the test when switching to single queue mode (num_queues=1) ?
> 
> Thanks,
> Vadim.

Hi Vadim,
   All jobs could pass with the following cli.Besides,QE don't explicitly declare that num_queues=1 in cli and just don't add it.
   cli,
   /usr/libexec/qemu-kvm -name 109SCS200832DYO -enable-kvm -m 4G -smp 4 -uuid 656b7110-5ca6-454b-89d5-b1ee22cac09d -nodefconfig -nodefaults -cpu Nehalem,+fsgsbase -chardev socket,id=charmonitor,path=/tmp/109SCS200832DYO,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x9 -drive file=109SCS200832DYO,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi1.0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x86_dvd_342333.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=109SCS200832DYO.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:54:71:e9:fd,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7 -drive file=109SCS200832DYO_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0


  Any issues please let me know ! thanks !

Min Deng
Comment 10 Yu Wang 2016-07-05 04:47:17 EDT
Hi,

According to our vioscsi WHQL test, all job passed on win2008-64 w/ multiqueue, so this bug has been fixed.

Thanks
Yu Wang
Comment 11 Yu Wang 2016-07-05 04:48:13 EDT
(In reply to Yu Wang from comment #10)
> Hi,
> 
> According to our vioscsi WHQL test, all job passed on win2008-64 w/
> multiqueue, so this bug has been fixed.
> 
> Thanks
> Yu Wang

Sorry , version is virtio-win-prewhql-120
Comment 13 Yu Wang 2016-07-05 05:49:12 EDT
According to comment#10, this bug has been fixed, change status to verified.
Comment 15 errata-xmlrpc 2016-11-04 04:48:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html

Note You need to log in before you can comment on or make changes to this bug.