Bug 124989 - Spurious "Obsoletes: juk"
Summary: Spurious "Obsoletes: juk"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-01 20:00 UTC by Ville Skyttä
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-03 13:14:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2004-06-01 20:00:07 UTC
kdemultimedia-3.2.2-2 obsoletes juk, but is not built with it.  This
will probably go away in FC3 if juk will be built.  Trivial patch for
the record:

--- kdemultimedia.spec~  2004-05-05 18:10:23.000000000 +0300
+++ kdemultimedia.spec   2004-06-01 22:51:46.262586660 +0300
@@ -87,7 +87,9 @@
 Obsoletes: koncd
 Obsoletes: kscd
 Obsoletes: aktion
+%if %{juk}
 Obsoletes: juk
+%endif

 Provides: %{name}-libs
 Provides: %{name}-brahms

Comment 1 Ngo Than 2004-06-02 08:13:15 UTC
the reason why i have added the "Obsoletes: juk" in the spec file, is
that if someone wants to rebuild kdemultimedia with juk and has
installed juk as separate package on machine before, it should work
for them.

Comment 2 Ville Skyttä 2004-06-02 14:58:47 UTC
That's fine /iff/ kdemultimedia is built with juk.  But the current
package as provided in FC2 is *not* built with it.

Currently the "Obsoletes: juk" as set in the FC2 package causes
problems with external juk packages, ie. they are obsoleted and thus
removed by this package, but there's no replacement provided -> loss
of functionality.

juk should be only obsoleted if it is built, that is what the patch in
my initial submission does.

Comment 3 Ngo Than 2004-06-03 13:14:41 UTC
it's fixed in kdemultimedia-3.2.2-3 or newer. Thanks


Note You need to log in before you can comment on or make changes to this bug.