Bug 1249890 - Support heartbeats on qpid 5647 port
Support heartbeats on qpid 5647 port
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.8
All Linux
medium Severity high (vote)
: 6.1.3
: --
Assigned To: Stephen Benjamin
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 23:54 EDT by Amit Upadhye
Modified: 2017-07-26 15:37 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 14:20:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hotfix packages (1.59 MB, application/x-gzip)
2015-10-01 11:04 EDT, Mike McCune
no flags Details
hotfix packages RHEL6 (1.61 MB, application/x-gzip)
2015-10-08 11:15 EDT, Mike McCune
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1554243 None None None Never
Pulp Redmine 1232 High CLOSED - CURRENTRELEASE Enable heartbeats in the proton messaging adapter in goferd Never

  None (edit)
Description Amit Upadhye 2015-08-03 23:54:48 EDT
1. Proposed title of this feature request  

Request for documentation on how to enable heartbeats on qpid 5647 port ?

2. Who is the customer behind the request?  
Account: RED HAT IT/IS and acct #5243891
  
TAM customer: yes  
SRM customer: yes  
Strategic: yes  
  
3. What is the nature and description of the request?  

On Satellite 6.1 goferd connects to qdrouterd on ports 5646 and 5647. As per customer firewall torn down the 5647 connections silently after a few hours due to no traffic. Since the connection has closed without reset sent, goferd and qdrouterd on both side still thinks the connection is "active", so they didn't even try to reconnect. To avoid such issues required to add heartbeats on 5647 port too.

4. Why does the customer need this? (List the business requirements here)  

To avoid silent capsule sync hangs.

5. How would the customer like to achieve this? (List the functional requirements here)  

By adding heartbeats on 5647 port too.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented. 

Confirming capsule syncs are not hanging because of having heartbeats on 5647 port too.
  
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

No.
  
8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
 
No.

9. Is the sales team involved in this request and do they have any additional input?  

No.

10. List any affected packages or components.  

Unknown.

11. Would the customer be able to assist in testing this functionality if implemented?

Yes.
Comment 19 Stephen Benjamin 2015-08-04 20:10:11 EDT
Created redmine issue http://projects.theforeman.org/issues/11291 from this bug
Comment 29 pulp-infra@redhat.com 2015-09-03 15:00:19 EDT
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 30 pulp-infra@redhat.com 2015-09-03 15:00:21 EDT
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.
Comment 33 pulp-infra@redhat.com 2015-09-10 13:30:23 EDT
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.
Comment 36 pulp-infra@redhat.com 2015-09-11 15:30:16 EDT
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.
Comment 38 pulp-infra@redhat.com 2015-09-24 12:00:24 EDT
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.
Comment 40 Mike McCune 2015-10-01 10:59:22 EDT
== HOTFIX Instructions for RHEL7 ==

0) Download the attached tar.gz file to your Satellite and Capsules from this bugzilla, extract it to /var/tmp/qpid-heartbeat

1) On your Satellite and Capsule, configure a yum repository to point at:

[qpid-heartbeat-hotfix]
name=qpid-heartbeat-hotfix
gpgcheck=0
enabled=1
baseurl=file:///var/tmp/qpid-heartbeat

2) execute 'yum update' on both the Capsule and Satellite

3) Edit /etc/qpid-dispatch/qdrouterd.conf

Add "idle-timeout-seconds: 0" to the connector section, eg:

connector {
    name: broker
    addr: sat.example.com
    port: 5671
    sasl-mechanisms: ANONYMOUS
    role: on-demand
    ssl-profile: client
    idle-timeout-seconds: 0
}

4) run 'katello-service restart' on the Satellite and Capsule

5) proceed with operations
Comment 41 Stuart Auchterlonie 2015-10-01 11:02:11 EDT
Step 4b) run `systemctl restart goferd` on the capsules

otherwise you will pretty quickly hit the error
"Host did not respond within 20 seconds. Is katello-agent installed and goferd running on the Host?"
Comment 42 Mike McCune 2015-10-01 11:04 EDT
Created attachment 1079186 [details]
hotfix packages
Comment 50 Corey Welton 2015-10-05 11:18:56 EDT
QE notes:  test with a configuration where there is a firewall between capsule and server, where idle connections are dropped.
Comment 52 Tazim Kolhar 2015-10-06 07:29:03 EDT
Hi,

    please provide verification steps
    thanks

thanks and regards,
Tazim
Comment 53 jcallaha 2015-10-07 14:48:23 EDT
Verified on Satellite-6.1.0-20151006.0

In and Out connections on 5647 dropped and brought back. Was able to install and remove packages with no errors.
Comment 54 Mike McCune 2015-10-08 11:15 EDT
Created attachment 1081045 [details]
hotfix packages RHEL6
Comment 56 errata-xmlrpc 2015-10-15 14:20:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911
Comment 57 pulp-infra@redhat.com 2015-11-09 16:00:48 EST
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Note You need to log in before you can comment on or make changes to this bug.