Bug 1249982 - python-qpid-common depends on libstdc++.so.6 and Boost
python-qpid-common depends on libstdc++.so.6 and Boost
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Irina Boverman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 05:59 EDT by Jonathan Wakely
Modified: 2015-09-25 03:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 03:56:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for the rawhide spec file. (1.32 KB, patch)
2015-08-04 06:02 EDT, Jonathan Wakely
no flags Details | Diff

  None (edit)
Description Jonathan Wakely 2015-08-04 05:59:04 EDT
Description of problem:

rpm -q --requires python-qpid-common
/usr/bin/env
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libm.so.6()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libqpidmessaging.so.2()(64bit)
libqpidtypes.so.1()(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
python(abi) = 2.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)

The libqpidmessaging.so.2 and libqpidtypes.so.1 libraries are part of qpid-cpp-client which requires boost.

These dependencies are bogus, the Python client does not require the C++ client, so should not depend on it, not the C++ runtime libraries.

This means that the Fedora build of the rhpkg tool used to build RHEL unnecessarily depends on Boost even though it only uses the Python qpid bindings. This should be fixed.

Version-Release number of selected component (if applicable):

python-qpid-common-0.32-4.fc22.x86_64


How reproducible:

Always


Additional info:

The bogus dependencies are due to the following section of the spec file:

 %files -n python-qpid-common
 %doc LICENSE
 %doc examples

The examples dir contains C++ examples, including compiled object files that depend on libstdc++.so

These should not be included in the python-qpid-common subpackage, C++ example files are of no interest to users of the Python bindings.
Comment 1 Jonathan Wakely 2015-08-04 06:02:40 EDT
Created attachment 1058999 [details]
Patch for the rawhide spec file.

This removes the unnecessary '%doc examples' line, and also fixes the %description for the qpid-client-devel subpackage, which claims to install documentation for the C++ client, but that is actually packaged separately in qpid-cpp-client-devel-docs.
Comment 2 Jonathan Wakely 2015-08-18 14:18:33 EDT
The unwanted C++ dependencies only seem to be a problem with the Fedora packages, python-qpid in rhel6 and rhel7 is OK, so users of 'rhpkg' on RHEL do not depend on Boost.
Comment 3 Fedora Update System 2015-09-23 12:30:00 EDT
python-qpid-0.32-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16537
Comment 4 Fedora Update System 2015-09-23 23:31:45 EDT
python-qpid-0.32-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-qpid'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16537
Comment 5 Fedora Update System 2015-09-25 03:56:53 EDT
python-qpid-0.32-9.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.