Bug 1249983 - Rebalance is failing in test cluster framework.
Rebalance is failing in test cluster framework.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.3
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Anand Nekkunti
:
Depends On: 1231437
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 06:02 EDT by Anand Nekkunti
Modified: 2016-01-03 23:50 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1231437
Environment:
Last Closed: 2015-09-09 05:39:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nekkunti 2015-08-04 06:02:11 EDT
+++ This bug was initially created as a clone of Bug #1231437 +++

Description of problem:
 Rebalance is not working in cluster test framework.


How reproducible: Always


Steps to Reproduce:
find attached test file.

prove -vf tests/bugs/glusterd/1229139.t

It is happening in test frame work ( any simulated cluster environment in same node ) only.
RCA:
  1. we are passing always "localhost" as volfile server for rebalance xlator .
  2.Rebalance processes are  overwriting  unix socket and log files each other (All rebalance processes are creating socket with same name) .

--- Additional comment from Anand Avati on 2015-06-13 08:19:39 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: rebalance is failing in cluster.rc framework) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-13 08:47:29 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: Rebalance is failing in cluster.rc framework) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-15 05:00:04 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: rebalance support for cluster.rc framework) posted (#3) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-19 10:39:12 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: rebalance support for cluster.rc framework) posted (#4) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-21 11:11:15 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: rebalance support for cluster.rc framework) posted (#5) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-25 13:37:28 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: rebalance support for cluster.rc framework) posted (#6) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-26 09:34:49 EDT ---

REVIEW: http://review.gluster.org/11210 (glusterd: rebalance support for cluster.rc framework) posted (#7) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-07-17 02:40:13 EDT ---

COMMIT: http://review.gluster.org/11210 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit ee824ccb10e28489907fbf978a2d36b0b2c5dc8c
Author: anand <anekkunt@redhat.com>
Date:   Sat Jun 13 16:46:10 2015 +0530

    glusterd: rebalance support for cluster.rc framework
    
    Issue:Rebalance is failing in cluster framework (any simulated cluster environment in same node ).
    RCA:
      1. we are passing always "localhost" as volfile server for rebalance xlator .
      2. Rebalance daemons are overwriting  unix socket and log files each other.
         (All rebalance processes are creating socket with same name) .
    
    Fix: set vol_file_server, unix socket and log files properly.
    
    Change-Id: I6654461e00c2a164b2f1f1db24a316c4180dd8d5
    BUG: 1231437
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/11210
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 1 Anand Avati 2015-08-04 06:06:51 EDT
REVIEW: http://review.gluster.org/11824 (glusterd: rebalance support for cluster.rc framework) posted (#1) for review on release-3.7 by Anand Nekkunti (anekkunt@redhat.com)
Comment 2 Anand Avati 2015-08-06 00:16:58 EDT
REVIEW: http://review.gluster.org/11824 (glusterd: rebalance support for cluster.rc framework) posted (#2) for review on release-3.7 by Anand Nekkunti (anekkunt@redhat.com)
Comment 3 Anand Avati 2015-08-06 08:13:33 EDT
COMMIT: http://review.gluster.org/11824 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit b8120c91cb11de7b21f2d6a36f7dc89ad0b7c387
Author: anand <anekkunt@redhat.com>
Date:   Sat Jun 13 16:46:10 2015 +0530

    glusterd: rebalance support for cluster.rc framework
    
    Issue:Rebalance is failing in cluster framework (any simulated cluster environment in same node ).
    RCA:
      1. we are passing always "localhost" as volfile server for rebalance xlator .
      2. Rebalance daemons are overwriting  unix socket and log files each other.
         (All rebalance processes are creating socket with same name) .
    
    Fix: set vol_file_server, unix socket and log files properly.
    Back portof:
    >Change-Id: I6654461e00c2a164b2f1f1db24a316c4180dd8d5
    >BUG: 1231437
    >Signed-off-by: anand <anekkunt@redhat.com>
    >Reviewed-on: http://review.gluster.org/11210
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >(cherry picked from commit ee824ccb10e28489907fbf978a2d36b0b2c5dc8c)
    
    Change-Id: I31a97c6186efa36d568c469a2320a4f3e870f781
    BUG: 1249983
    Reviewed-on: http://review.gluster.org/11824
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Kaushal 2015-09-09 05:39:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.