Bug 1249998 - Unable to install rpm in GUI using default package manager
Unable to install rpm in GUI using default package manager
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.2
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
Jana Heves
:
Depends On:
Blocks: 1246125 1259988 1264318
  Show dependency treegraph
 
Reported: 2015-08-04 06:18 EDT by Ladislav Kolacek
Modified: 2015-11-19 04:19 EST (History)
6 users (show)

See Also:
Fixed In Version: PackageKit-1.0.7-5.el7
Doc Type: Known Issue
Doc Text:
GNOME software does not support GetDetailsLocal GNOME software does not support the GetDetailsLocal back end method, which means that RPM files cannot be installed using GUI. As a workaround, download the RPM and run the "sudo yum localinstall $rpm" command in the terminal.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:19:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnomeSoftware.png (150.65 KB, image/png)
2015-08-04 06:18 EDT, Ladislav Kolacek
no flags Details

  None (edit)
Description Ladislav Kolacek 2015-08-04 06:18:57 EDT
Created attachment 1059008 [details]
gnomeSoftware.png

Description of problem:

Version-Release number of selected component (if applicable):
rpm-4.11.3-13.el7.x86_64
kernel-3.10.0-300.el7.x86_64
gnome-software-3.14.6-5.el7.x86_64
yum-3.4.3-129.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Download rpm package (e.g. mc from https://brewweb.devel.redhat.com/)
2. Start installation by double clicking on rpm package

Actual results: Gnome software starts with error message (see attachment):
  Sorry this did not work
  GetDetailsLocal not supported by backend 

Expected results:
Component should be successfully installed

Additional info:
It is possible to install component by terminal:
yum install someComponent.rpm
Comment 1 Jan Zeleny 2015-08-04 09:23:21 EDT
I'm not sure why is this filed against rpm. As you wrote, it is possible to install the component via yum, therefore it's unlikely an issue of rpm or yum. Reassigning ...
Comment 2 Ladislav Kolacek 2015-08-04 10:47:51 EDT
Thank you for your correction.
Comment 3 Matthias Clasen 2015-08-05 11:16:17 EDT
clearly something we need to fix
Comment 4 Richard Hughes 2015-08-05 12:25:12 EDT
commit a15ce85d03ba9babc2cbe100204c12f08500134c
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 5 17:24:03 2015 +0100

    yum: Add support for GetDetailsLocal
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1249998
Comment 10 errata-xmlrpc 2015-11-19 04:19:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2139.html

Note You need to log in before you can comment on or make changes to this bug.