Bug 1250007 - Atomic install with --display option doestn't work
Atomic install with --display option doestn't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 06:39 EDT by Alex Jia
Modified: 2016-03-31 19:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:24:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2015-08-04 06:39:06 EDT
Description of problem:
Atomic install with --display option doestn't work, and atomic run still preview
the command without --display option.

Version-Release number of selected component (if applicable):
# rpm -q atomic docker kernel
atomic-1.0-108.el7.x86_64
docker-1.7.1-108.el7.x86_64
kernel-3.10.0-123.6.3.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. atomic install --display <container>
2. atomic run <container>


Actual results:
1. atomic install --display <container>

Note: nothing output

2. atomic run <container>

Note: e.g. the container is busybox, the output as following:
/usr/bin/docker create -t -i --name busybox busybox /bin/sh
busybox

Expected results:
# atomic install --display busybox
/usr/bin/docker run -t -i --rm --privileged -v /:/host --net=host --ipc=host --pid=host -e HOST=/host -e NAME=busybox -e IMAGE=busybox -v /etc/busybox:/etc/busybox -v /var/log/busybox:/var/log/busybox -v /var/lib/busybox:/var/lib/busybox -e CONFDIR=/etc/busybox -e LOGDIR=/var/log/busybox -e DATADIR=/var/lib/busybox --name busybox busybox /bin/sh

# atomic run busybox

Without command preview.

Additional info:

Comitted a PR to fix this issue https://github.com/projectatomic/atomic/pull/107
Comment 2 Daniel Walsh 2015-12-01 17:08:10 EST
Fixed in atomic-1.5-2.git191fb53.el7
Comment 4 Alex Jia 2016-01-20 05:43:56 EST
Everything is okay on atomic-1.8-4.git958d939.el7.x86_64, so move the bug to VERIFIED status.

# atomic run busybox
/ # exit

# atomic info centos_stop_label | grep RUN
RUN: /usr/bin/docker run -t --user ${SUDO_UID}:${SUDO_GID} ${OPT1}  -v /var/log/${NAME}:/var/log -v /var/lib/${NAME}:/var/lib $OPT2 --name ${NAME} ${IMAGE} $OPT3 echo I am the run label.

# atomic  run --display centos_stop_label
/usr/bin/docker run -t --user 0:0  -v /var/log/centos_stop_label:/var/log -v /var/lib/centos_stop_label:/var/lib  --name centos_stop_label centos_stop_label  echo I am the run label.

# atomic info centos_stop_label | grep INSTALL
INSTALL: /usr/bin/docker ${OPT1} run  -v /etc/${NAME}:/etc -v /var/log/${NAME}:/var/log -v /var/lib/${NAME}:/var/lib $OPT2 --name ${NAME} ${IMAGE} $OPT3 echo I am the install label.

# atomic install --display centos_stop_label
/usr/bin/docker  run -v /etc/centos_stop_label:/etc -v /var/log/centos_stop_label:/var/log -v /var/lib/centos_stop_label:/var/lib  --name centos_stop_label centos_stop_label  echo I am the install label.

# atomic install centos_stop_label
/usr/bin/docker  run -v /etc/centos_stop_label:/etc -v /var/log/centos_stop_label:/var/log -v /var/lib/centos_stop_label:/var/lib  --name centos_stop_label centos_stop_label  echo I am the install label.
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.
I am the install label.
Comment 6 errata-xmlrpc 2016-03-31 19:24:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0527.html

Note You need to log in before you can comment on or make changes to this bug.