Bug 1250010 - The GUI is stuck in status "saving" when glance returns an error, instead of displaying the error
The GUI is stuck in status "saving" when glance returns an error, instead of ...
Status: ASSIGNED
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 11.0 (Ocata)
Assigned To: Radomir Dopieralski
Ola Pavlenko
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 06:49 EDT by Udi
Modified: 2017-11-21 21:47 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2015-08-04 06:49:51 EDT
Description of problem:
I uploaded an image to glance and waited for a really long time. The GUI still showed the image in "saving" status... To see if this is also happening from the command line, I tried a 'glance image-create' command and it returned an error almost immediately:

Error finding address for http://192.0.2.9:9292/v1/images: [Errno 32] Broken pipe

The GUI never fails (it's been running here for ~3 hours) and the GUI user doesn't have a chance to know that there is a problem.


Version-Release number of selected component (if applicable):
python-django-horizon-2015.1.0-10.el7ost.noarch


How reproducible:
When the glance service is unresponsive


Steps to Reproduce:
1. Make sure glance doesn't handle any requests. It happened to me after a power outage and we're still investigating why exactly glance was stuck.
2. Log in to horizon
3. Upload an image


Actual results:
The upload never progresses at all
Comment 3 Matthias Runge 2015-10-13 15:30:19 EDT
Liberty has no feature added, I believe we'll benefit from a notification mechanism, hopefully added during mitaka dev cycle.
Comment 4 Itxaka 2016-04-22 07:31:44 EDT
I could reproduce this by:

 - Filling the new image form and saving it
 - While the image is being saved, kill all glance services over and over


Result:
Image is in saving status.



I dont know if this is an horizon issue. The image returned from glance directly has that status on my test so horizon is just showing what glance returns, its not making any decisions on whats in there or what status is on the image.

[root@openstack ~(keystone_admin)]# glance image-show a0e380bc-4ad9-4836-af97-715eed3d33b3
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | bare                                 |
| created_at       | 2016-04-22T11:26:32Z                 |
| description      |                                      |
| disk_format      | iso                                  |
| id               | a0e380bc-4ad9-4836-af97-715eed3d33b3 |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | fghfg                                |
| owner            | 5e81561e7475442986c28910989e0081     |
| protected        | False                                |
| size             | 277872640                            |
| status           | saving                               |
| tags             | []                                   |
| updated_at       | 2016-04-22T11:26:32Z                 |
| virtual_size     | None                                 |
| visibility       | private                              |
+------------------+--------------------------------------+



So from my point of view, the problem does _not_ lie in horizon, it is on glance. The image saving action was cut and the image is stuck in that status forever, when it should go to error.


Would be good to get a comment on this, as looks to me a NOTABUG
Comment 5 Udi 2016-04-24 02:53:21 EDT
The difference is that you interrupted an upload while it was saving, and indeed you can open a bun on glance with this scenario. In the original bug, glance behaved ok by immediately returning an error, and in horizon the status was shown incorrectly. But it's hard to recreate such a situation.
Comment 6 Itxaka 2016-04-25 05:31:14 EDT
Understood, any hint on how I could reproduce this? What was the issue with glance in that installation, so I may be able to reproduce this manually by breaking glance.
Comment 7 Udi 2016-04-25 06:19:38 EDT
It broke as a result of a power outage, which is difficult to reproduce. You can try breaking glance in some other way(s), like misconfiguring the service or disconnecting its backend etc... I also googled for the error message "[Errno 32] Broken pipe" and found several bugs on glance that cause this error, but I couldn't deduce what the scenario was to recreate them also. I'm sorry that I don't have a more exact answer.
Comment 9 Jason E. Rist 2016-10-18 11:39:55 EDT
• not clear how to reproduce
• might benefit from general hardening of the glance status handling
• needs to be worked on upstream

Note You need to log in before you can comment on or make changes to this bug.