Bug 1250066 - SELinux:AVC's related to sshd and samba when ssh to server
SELinux:AVC's related to sshd and samba when ssh to server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.7
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 08:37 EDT by surabhi
Modified: 2016-05-10 16:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-282.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:00:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0763 normal SHIPPED_LIVE selinux-policy bug fix update 2016-05-10 18:33:46 EDT

  None (edit)
Description surabhi 2015-08-04 08:37:53 EDT
Description of problem:
With SELinux in enforcing mode, there are following AVC's seen while verifying the AD setup and domain user login.
type=SYSCALL msg=audit(08/04/2015 12:13:56.464:2106) : arch=x86_64 syscall=lstat success=no exit=-13(Permission denied) a0=0x7f05c47ac9f1 a1=0x7ffd2d918a90 a2=0x7ffd2d918a90 a3=0x7ffd2d91bd70 items=0 ppid=2043 pid=7059 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=sshd exe=/usr/sbin/sshd subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null) 
type=AVC msg=audit(08/04/2015 12:13:56.464:2106) : avc:  denied  { search } for  pid=7059 comm=sshd name=samba dev=dm-0 ino=1177567 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:smbd_var_run_t:s0 tclass=dir 
----
type=SYSCALL msg=audit(08/04/2015 12:14:01.387:2124) : arch=x86_64 syscall=lstat success=no exit=-13(Permission denied) a0=0x7f05c47ac9f1 a1=0x7ffd2d918460 a2=0x7ffd2d918460 a3=0x1 items=0 ppid=7059 pid=7073 auid=root uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=pts0 ses=323 comm=sshd exe=/usr/sbin/sshd subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null) 
type=AVC msg=audit(08/04/2015 12:14:01.387:2124) : avc:  denied  { search } for  pid=7073 comm=sshd name=samba dev=dm-0 ino=1177567 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:smbd_var_run_t:s0 tclass=dir 
----
type=SYSCALL msg=audit(08/04/2015 12:14:56.008:2140) : arch=x86_64 syscall=lstat success=yes exit=0 a0=0x7f49be8b79f1 a1=0x7fffcd1873a0 a2=0x7fffcd1873a0 a3=0x7fffcd189870 items=0 ppid=2043 pid=7096 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=sshd exe=/usr/sbin/sshd subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null) 
type=AVC msg=audit(08/04/2015 12:14:56.008:2140) : avc:  denied  { search } for  pid=7096 comm=sshd name=samba dev=dm-0 ino=1177567 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:smbd_var_run_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-279.el6_7.3.noarch
selinux-policy-targeted-3.7.19-279.el6_7.3.noarch


How reproducible:
only once when do ssh.

Steps to Reproduce:
1.Setup AD setup
2. domain user login
3. ssh to samba server

Actual results:
AVC seen :
type=AVC msg=audit(08/04/2015 12:14:56.008:2140) : avc:  denied  { search } for  pid=7096 comm=sshd name=samba dev=dm-0 ino=1177567 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:smbd_var_run_t:s0 tclass=dir


Expected results:
There should not be any AVC.

Additional info:
Comment 5 errata-xmlrpc 2016-05-10 16:00:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0763.html

Note You need to log in before you can comment on or make changes to this bug.