Bug 1250073 - redis fails to start when db is 0 bytes
redis fails to start when db is 0 bytes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.1
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
Asaf Hirshberg
: ZStream
Depends On: 1231032
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 09:00 EDT by Jan Kurik
Modified: 2015-09-15 05:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-40.el7_1.7
Doc Type: Bug Fix
Doc Text:
When a cluster node fails, the /var/lib/redis/dump.rdb database file in some cases changes its size to 0 bytes. Previously, when this happened, the Redis Open Clustering Framework (OCF) resource agent did not start correctly. This update ensures that in the described situation, Redis automatically clears the corrupted database file and resynchronizes the remaining Redis instances in the cluster. As a result, Redis starts as expected.
Story Points: ---
Clone Of: 1231032
Environment:
Last Closed: 2015-09-15 05:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cat /var/log | grep redis (5.36 KB, text/plain)
2015-08-12 05:21 EDT, Asaf Hirshberg
no flags Details
redis.log (51.37 KB, text/plain)
2015-08-26 06:58 EDT, Asaf Hirshberg
no flags Details
redis.log (51.37 KB, text/plain)
2015-08-26 07:00 EDT, Asaf Hirshberg
no flags Details

  None (edit)
Description Jan Kurik 2015-08-04 09:00:39 EDT
This bug has been copied from bug #1231032 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 5 Asaf Hirshberg 2015-08-12 05:21:09 EDT
Created attachment 1061889 [details]
cat /var/log | grep redis
Comment 9 Asaf Hirshberg 2015-08-26 06:57:46 EDT
Verified,


[root@overcloud-controller-2 ~]# rpm -qa |grep resource
resource-agents-3.9.5-40.el7_1.7.x86_64

1. rm /var/lib/redis/dump.rdb && touch /var/lib/redis/dump.rdb
2. Verify the redis agent successfully starts on that node.

[root@overcloud-controller-2 ~]# pcs status
Cluster name: tripleo_cluster
....
Master/Slave Set: redis-master [redis]
     Masters: [ overcloud-controller-0 ]
     Slaves: [ overcloud-controller-1 overcloud-controller-2 ]
....

redis logs attached
Comment 10 Asaf Hirshberg 2015-08-26 06:58:47 EDT
Created attachment 1067222 [details]
redis.log
Comment 11 Asaf Hirshberg 2015-08-26 07:00:07 EDT
Created attachment 1067225 [details]
redis.log
Comment 14 errata-xmlrpc 2015-09-15 05:38:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1791.html

Note You need to log in before you can comment on or make changes to this bug.