Bug 1250113 - coreutils doesn't include a base32 binary
coreutils doesn't include a base32 binary
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 10:30 EDT by Nikos Mavrogiannopoulos
Modified: 2016-05-11 12:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: coreutils-8.25-2.fc24
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 12:09:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
base32 program (10.68 KB, patch)
2015-08-05 04:46 EDT, Nikos Mavrogiannopoulos
no flags Details | Diff
base32 program (10.68 KB, patch)
2015-08-05 05:25 EDT, Nikos Mavrogiannopoulos
no flags Details | Diff

  None (edit)
Description Nikos Mavrogiannopoulos 2015-08-04 10:30:06 EDT
Description of problem:
coreutils includes a base64 encoder, but no base32 (or base16). The base32 encoding is very useful for converting OTP keys to a format programs like freeotp accept, and is becoming very popular for URL encoding of data.

All the encodings are described in rfc4648.

Additional info:
Please include a base32 convertor in fedora.
Comment 1 Pádraig Brady 2015-08-04 11:30:53 EDT
Maybe. Please discuss upstream at coreutils@gnu.org though.

See also related discussion at:
http://lists.gnu.org/archive/html/bug-coreutils/2010-04/msg00195.html

Note for URL encoding, base64 is almost perfect and could be tweaked like:

  b64_url_encode() { base64 | tr '+/=' '-_.'; }
  b64_url_decode() { tr -- '-_.' '+/=' | base64 -d; }
Comment 2 Nikos Mavrogiannopoulos 2015-08-04 11:54:16 EDT
I would expect the maintainers of coreutils to talk upstream. I could help if required.
Comment 3 Ondrej Vasik 2015-08-04 16:42:38 EDT
Nikos, for Fedora, it is better if you will discuss this RFE upstream, as you will likely better defend it. And there are many todo tasks... so with patch chances are even higher. Without your proposal upstream and/or patch, I can only put this to the long term todo list.

btw. Pádraig Brady is one of Fedora co-maintainers and upstream (nowadays primary) maintainer.
Comment 4 Nikos Mavrogiannopoulos 2015-08-05 04:46:12 EDT
Created attachment 1059379 [details]
base32 program

This patch adds the base32 program. The need for such a program is because base32 is increasingly used in URLs and QR codes and we have no simple tool to generate such codes. In particular I noticed there were no command line tools to generate otpauth codes as in:
https://github.com/google/google-authenticator/wiki/Key-Uri-Format
Comment 6 Nikos Mavrogiannopoulos 2015-08-05 05:25:58 EDT
Created attachment 1059388 [details]
base32 program
Comment 7 Pádraig Brady 2015-08-05 06:03:47 EDT
Please implement like sha1sum. I.E. reuse base64.c. See src/local.mk for details. Then please post to coreutils@gnu.org. Thanks.
Comment 9 Ondrej Vasik 2015-08-05 09:12:55 EDT
Thanks Pádraig and Nikos!
Comment 10 Pádraig Brady 2015-09-01 11:05:37 EDT
Upstream proposal:
http://lists.gnu.org/archive/html/coreutils/2015-09/msg00000.html
Comment 12 Kamil Dudka 2016-05-11 12:09:29 EDT
This seems to be already fixed since coreutils-8.25-2.fc24.

Note You need to log in before you can comment on or make changes to this bug.