Bug 1250123 - Fails when run inside mock
Fails when run inside mock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm-ostree (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
Depends On:
Blocks: F23AlphaFreezeException
  Show dependency treegraph
 
Reported: 2015-08-04 10:49 EDT by Colin Walters
Modified: 2015-08-07 23:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: rpm-ostree-2015.8-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-07 23:16:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2015-08-04 10:49:20 EDT
Should be fixed by https://github.com/projectatomic/rpm-ostree/releases/tag/v2015.8
Comment 1 Fedora Blocker Bugs Application 2015-08-04 10:51:30 EDT
Proposed as a Blocker for 23-alpha by Fedora user walters using the blocker tracking app because:

 Breaks Atomic 23 composes
Comment 2 Fedora Update System 2015-08-04 18:37:54 EDT
rpm-ostree-2015.8-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/rpm-ostree-2015.8-1.fc23
Comment 3 Adam Williamson 2015-08-04 18:39:40 EDT
AFAIK there's still no certainty on whether Atomic images are blockers for Fedora releases: https://fedorahosted.org/fesco/ticket/1452 suggests an entirely separate, parallel release process for Atomic.

On that basis, I'm going to vote +/-0 blocker, +1 FE for this (unless FESCo clarifies the status of the Atomic images). Other votes?
Comment 4 Kevin Fenzi 2015-08-04 18:41:57 EDT
+1 FE for now at least
Comment 5 Adam Williamson 2015-08-04 18:43:44 EDT
I'll note that https://fedoraproject.org/w/index.php?title=Cloud/Cloud_PRD&diff=416086&oldid=416078 adds "Atomic Host" as a "Feature" in the Cloud PRD, but I'm not entirely clear on what the practical effect of that is/should be.
Comment 6 Mike Ruckman 2015-08-04 18:51:51 EDT
+1 FE - Atomic is a spin now, so it doesn't block.
Comment 7 Adam Williamson 2015-08-04 18:52:50 EDT
With Mike's note, I'm -1 blocker / +1 FE. We have +3 FE at this point, so marking AcceptedFreezeException.
Comment 8 Fedora Update System 2015-08-04 20:12:01 EDT
Package rpm-ostree-2015.8-1.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-ostree-2015.8-1.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12738/rpm-ostree-2015.8-1.fc23
then log in and leave karma (feedback).
Comment 9 Stephen Gallagher 2015-08-05 14:33:23 EDT
-1 blocker, +1 FE

ISTR that atomic was made non-blocking while the new two-week delivery plan was sorted out.
Comment 10 Adam Williamson 2015-08-05 14:58:54 EDT
That's -3 blocker (with Mike's), so marking rejectedblocker.
Comment 11 Dennis Gilmore 2015-08-05 15:00:46 EDT
+1 FE
Comment 12 Fedora Update System 2015-08-07 23:16:49 EDT
rpm-ostree-2015.8-1.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.